Ranorex v8.3.0 Flash in Chrome

Ask general questions here.
[email protected]
Posts: 6
Joined: Wed Oct 17, 2018 6:12 pm

Ranorex v8.3.0 Flash in Chrome

Post by [email protected] » Wed Oct 24, 2018 8:48 pm

Hi,

I am creating a test in Chrome and it is prompting the tester to allow/enable the Flash plugin. Is there a way to set that at the beginning of the test to avoid further Flash messages?

Thanks,

Peter

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex v8.3.0 Flash in Chrome

Post by odklizec » Thu Oct 25, 2018 8:22 am

Hi,

As far as I know, there is no special option for this in OpenBrowser action (or any other Ranorex action). So I think you must either handle it with some additional Ranorex actions (either recorded or manually added), or maybe there is a command line option, which you can use in OpenBrowser action, and which may suppress this messages? Give google a try ;) Eventually, examine browser's/flash plugin settings.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

[email protected]
Posts: 6
Joined: Wed Oct 17, 2018 6:12 pm

Re: Ranorex v8.3.0 Flash in Chrome

Post by [email protected] » Fri Oct 26, 2018 4:59 pm

Hello,

I have installed the Ranorex Flash pre-loader for Chrome. When I come to the browser screen, my understanding is that the Flash plugin should be enabled. Is that correct? I still get prompted to "Click to Enable Adobe Flash Player". Not sure why.

Peter

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex v8.3.0 Flash in Chrome

Post by krstcs » Fri Oct 26, 2018 5:47 pm

Modern versions of Chrome (69+) require that you enable Flash/Flex each time you visit the site and want it to run. This is a Chrome security feature, not a Ranorex issue. In addition, Flash/Flex has been killed off by Adobe and will reach end-of-life in 2020. It should not be used anymore.

There is a way to enable Flash/Flex on modern Chrome versions through the hidden settings, but that is not a discussion for this site as it is not a Ranorex issue but a Chrome/Flash one, and there are multiple ways to do it, depending on how you are testing things. You can Google it.


NOTE: Seriously, stop using Flash/Flex. Your product needs to be moved to something else (HTML 5/JavaScript, etc.) as soon as possible. Adobe has already announced 2020 as the End-of-Life for Flash/Flex. So you have about 2 years to move your codebase to something else or your stuff likely won't work anymore. Google has already said Chrome will stop allowing ANY Flash/Flex at some point in 2020, as has Mozilla with Firefox (as in, there will be no way to get it to run - they are going to actively block it). You need to do this now, not 2020.

https://www.zdnet.com/article/chrome-69 ... en-harder/
Shortcuts usually aren't...

[email protected]
Posts: 6
Joined: Wed Oct 17, 2018 6:12 pm

Re: Ranorex v8.3.0 Flash in Chrome

Post by [email protected] » Fri Oct 26, 2018 7:17 pm

Hello,

Thank you for the comments and suggestions. I am new to requesting help on forums. This may be a Chrome issue, but why not include the suggestions here? I am encountering the issues while running RANOREX. Other users may get value from your answers.

Sincerely,

Peter

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex v8.3.0 Flash in Chrome

Post by krstcs » Fri Oct 26, 2018 7:49 pm

This is not a Ranorex issue, but a Chrome/Flash issue. It will happen if you uninstall Ranorex, and started with Chrome 69.

As I said, there are several solutions, and none of us know the one that is right for you. Please search Google, as there are several (dozens!) of possible fixes, depending on your situation.
Shortcuts usually aren't...