Ranorex Versions

Ask general questions here.
mbrees86
Posts: 10
Joined: Mon May 13, 2019 8:30 pm

Ranorex Versions

Post by mbrees86 » Tue Aug 06, 2019 4:13 pm

Hi,

I'm guessing I know the answer but I wanted to make sure. If you are using Jenkins to run Ranorex on a slave machine. I'm guessing that the version of Ranorex has to match whatever version is in the Stash repository? I couldn't find this called out anywhere, but that's that the Ranorex agents behaved so I figured this would be similar.

Thanks!
Mike

User avatar
Support Team
Site Admin
Site Admin
Posts: 11999
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex Versions

Post by Support Team » Tue Aug 06, 2019 7:01 pm

Hi mbrees86,

Yes, the version of Ranorex's runtime libraries must match the same version of the Ranorex that was used to build the test. For a more hassle-free configuration, I recommend using the "Copy runtime to output" feature (see screenshot below). This will ensure the correct Ranorex runtime is being used on the runtime machine each time and will even work if different solutions use different versions of Ranorex. Note, the runtime machine should not have Ranorex installed if using this feature as it can lead to version mismatch issues.
1.png
1.png (34.03 KiB) Viewed 89 times

I hope this helps!

Cheers,
Ned
.
Image