Ranorex With Test Rail Connecting Login issue

Bug reports.
amitgupta
Posts: 8
Joined: Sun Mar 28, 2021 7:58 pm

Ranorex With Test Rail Connecting Login issue

Post by amitgupta » Tue Apr 13, 2021 8:30 pm

Dear Team

When I try to integrate Test Rail with Ranorex automation tool, I am getting Connection failed(Login Failed: Authentication Failed)error .I entered correct address with login credential because I was able to login successfully with test rail site.

Could any team provide valuable guidance for integrating Test Rail with ranorex successfully?

thanks
Amit
Attachments
ranorex test rail error.jpg
ranorex test rail error.jpg (165.56 KiB) Viewed 70 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6544
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex With Test Rail Connecting Login issue

Post by odklizec » Tue Apr 13, 2021 10:03 pm

Hi,

At first, are you using most recent Ranorex version? If not, please update Ranorex with most recent 9.5.

At next, are you sure there is enabled API option in TestRail? (see TestRail integration guide)
Do you have Admin prividleges in TestRail? It's a must!
And make sure there are enabled all required permissions at TestRail side (again, please consult TestRail integration guide, mentioned above).
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

amitgupta
Posts: 8
Joined: Sun Mar 28, 2021 7:58 pm

Re: Ranorex With Test Rail Connecting Login issue

Post by amitgupta » Fri Apr 16, 2021 10:28 am

Dear Team

First I would like to say thank you for providing your precious time to have a look on query . I have followed test rail integration guide and test rail webinar but still no clue/solution. Still Not able to connect test rail with ranorex tool.I have admin privledge and also enabled API for test rail.

I felt that test rail integration guide and test rail webinar is not good to provide sufficient information because new user /joiner /new experience guy face difficulty for the same topic.

Could you please provide proper steps for resolving this issue if you can ?

Thank you
Amit G
odklizec wrote:
Tue Apr 13, 2021 10:03 pm
Hi,

At first, are you using most recent Ranorex version? If not, please update Ranorex with most recent 9.5.

At next, are you sure there is enabled API option in TestRail? (see TestRail integration guide)
Do you have Admin prividleges in TestRail? It's a must!
And make sure there are enabled all required permissions at TestRail side (again, please consult TestRail integration guide, mentioned above).
Attachments
4-16-2021 2-58-41 PM.jpg
4-16-2021 2-58-41 PM.jpg (220.14 KiB) Viewed 56 times
4-16-2021 2-57-05 PM.jpg
4-16-2021 2-57-05 PM.jpg (172.58 KiB) Viewed 56 times
4-16-2021 2-52-17 PM.jpg
4-16-2021 2-52-17 PM.jpg (177.01 KiB) Viewed 56 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6544
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex With Test Rail Connecting Login issue

Post by odklizec » Fri Apr 16, 2021 10:59 am

Hi,

Thank you for the reply. As I mentioned before, you must be a TestRail Administrator to be able to integrate Ranorex with TestRail. Do you see "Admin" word beside your name in the list of Users? "Lead" role is not exactly Admin!
TestRail.png
TestRail.png (309.9 KiB) Viewed 54 times
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration