RanorexPath is not found in Ranorex Studio, but in Spy it works

Ranorex Spy, Recorder, and Studio.
andreas.mewald
Posts: 1
Joined: Sun Aug 30, 2020 12:22 pm

RanorexPath is not found in Ranorex Studio, but in Spy it works

Post by andreas.mewald » Sun Aug 30, 2020 12:30 pm

I'm just watching the RanorexPath webinar and playing arround with the Ranorex Demo App. I build up the following RanorexPath:

/form[@controlname='RxMainFrame']/?/?/tabpage[@accessiblename=$tabName]/?/?/text[@accessiblename='First name']

Above path can't be found in Ranorex Studio ("Edit with Spy"):

RanorexPathNotWorking.png
RanorexPathNotWorking.png (28.39 KiB) Viewed 36 times
When I start a separate Spy process, copy and paste the path, Spy can find and highlight the UI-item.

PathInSpyWorking.png
PathInSpyWorking.png (47.6 KiB) Viewed 36 times
Can someone explain why the SAME path is working in Spy and not in Studio?

Thx

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6180
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: RanorexPath is not found in Ranorex Studio, but in Spy it works

Post by odklizec » Wed Sep 02, 2020 7:51 am

Hi,

At first, are you using most recent Ranorex version? (9.3.2 or recently released 9.3.3)?

At next, are you sure that Studio Spy uses the same settings as standalone Spy? I would suggest to go to standalone Spy, export its settings and load them in Studio Spy.

And finally, in Studio Spy, remove [@accessiblename...] part of the text element xpath, then go to Browser & Results tab and see if there is a text element found. Then examine its properties and search for accessible name property. Is there any and if yes, what's its content?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration