Raw Text not Capturing the text correctly

Bug reports.
BSullivan
Posts: 29
Joined: Thu Jun 04, 2015 6:31 pm
Location: HorseHeads NY
Contact:

Raw Text not Capturing the text correctly

Post by BSullivan » Mon Jun 19, 2017 6:28 pm

I am going through my tests that are failing since upgrading to Ranorex 7 and I noticed a strange issue that I cannot nail down.

Here is a snapshot of the offender:
Rawtext_garbled.rxsnp
(185.92 KiB) Downloaded 21 times
I cannot figure out why the RawText is incorrect, I had a previous test that validated the presence of the text and now it is failing because Ranorex can no longer find the text "No measures selected for graphing.".
brokentext.png
brokentext.png (71.9 KiB) Viewed 523 times
I have already looked at most if not all of the settings that I can think of, removed and readded the parent element to the GDI list, and restarted the AUT, Ranorex, and my machine.

I am currently using Ranorex 7.01 and Windows 10.

Any ideas?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3922
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Raw Text not Capturing the text correctly

Post by odklizec » Tue Jun 20, 2017 7:43 am

Hi,

It looks like a bug in Ranorex GDI capture? Did it work OK in 6.x?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Raw Text not Capturing the text correctly

Post by Support Team » Tue Jun 20, 2017 11:51 am

Hello,

This is most likely related to a known GDI bug within Ranorex 7.0.1. The bug fix is scheduled for our Ranorex 7.1 release, which will be released by the end of June.

Please note, that the release might get delayed due to unforeseen reasons and that we reserve the right to change the roadmap at any time.

Sincerely,
Robert
.
Image

BSullivan
Posts: 29
Joined: Thu Jun 04, 2015 6:31 pm
Location: HorseHeads NY
Contact:

Re: Raw Text not Capturing the text correctly

Post by BSullivan » Tue Jun 20, 2017 1:39 pm

Awesome.

It did work properly in a previous version, but no longer having the older version installed I was unsure if it was a Ranorex bug or an issue with the new controls that we are implementing in the AUT.

This issue can wait until the next release to see if the fix rolls out with it.

Thanks again!!!

Vaughan.Douglas
Posts: 250
Joined: Tue Mar 24, 2015 5:05 pm
Location: Des Moines, Iowa, USA

Re: Raw Text not Capturing the text correctly

Post by Vaughan.Douglas » Tue Jun 20, 2017 3:12 pm

BSullivan wrote:Awesome.

It did work properly in a previous version, but no longer having the older version installed I was unsure if it was a Ranorex bug or an issue with the new controls that we are implementing in the AUT.

This issue can wait until the next release to see if the fix rolls out with it.

Thanks again!!!
You can always get older versions from the download page.
Doug Vaughan