Reading Variable value during recording fails test

Ranorex Spy, Recorder, and Studio.
vnet
Posts: 29
Joined: Tue Jul 24, 2012 8:13 pm

Reading Variable value during recording fails test

Post by vnet » Wed Jul 25, 2012 8:35 pm

I have recorded a couple of tests which runs fine but when I try to replace values(like filename etc.) with variable names test fails. I am making sure that I am assigning the variable to the xpath also. I am kinda puzzle since if I dont use variable name, test stores the location of mouse click which is a hit or miss on a diff computer. I am struggling with this for few days now :roll: I am sure the fix is trivial, any help is appreciated, thanks in advance 8)

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Reading Variable value during recording fails test

Post by Support Team » Thu Jul 26, 2012 12:46 pm

Hi,

It would be very helpful if you would send us some screenshots (e.g. of the recording with and without variables).
Also a snapshot of the items you have trouble with would be of help.
I am kinda puzzle since if I don't use variable name, test stores the location of mouse click which is a hit or miss on a diff computer.
Is this the requested behavior?

Maybe you can explain the problem in more detail.

For some general information about data driven testing have a look at Lesson 3: Data-Driven Testing.

Kind Regards,
Larissa
Ranorex Suppor Team
.
Image

vnet
Posts: 29
Joined: Tue Jul 24, 2012 8:13 pm

Re: Reading Variable value during recording fails test

Post by vnet » Tue Jul 31, 2012 10:13 pm

Thanks for the reply. My bad that I was replacing Mouse click location with the variable name.