Recognition failed of grid and plot

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
lisa
Posts: 1
Joined: Mon Nov 16, 2015 9:08 am

Recognition failed of grid and plot

Post by lisa » Wed Nov 18, 2015 8:34 am

I'm trying to automate the system testing of my project with Ranorex 5.4, but failed in recognizing some core elements as displayed in red rectangle in the attached screenshot. Could anyone please give me some advise? Attached please find the snapshots.
Thanks! :)
Attachments
screenshot.png
Screenshot
screenshot.png (184.33 KiB) Viewed 589 times
work list.rxsnp
grid snapshot
(30.53 KiB) Downloaded 45 times
novoexpress.rxsnp
plot snapshot
(231.09 KiB) Downloaded 40 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Recognition failed of grid and plot

Post by Support Team » Fri Nov 20, 2015 10:20 am

Hello Lisa,

After opening the attached snapshots, I can see that the following warning is displayed:
"The automating and the automated process do not have the same bit width and Ranorex was unable to start the 32/64 Bit Bridge. UI element identification capabilities for controls in that process are limited."

The mentioned error message can have several reasons, please check the following points:

• Make sure that the setting "Enable 32/64 Bit Bridge" is enabled in the Settings dialog.
• Make sure Ranorex is not installed on a network drive or encrypted folder
• Make sure any Anti-Virus software is turned off
• Uninstall Ranorex completely and afterwards re-install the latest release.
• Make sure the "Microsoft Visual C++ 2008 Redistributable" x86 and x64 packages are installed. These packages should be installed by default if you run the Ranorex setup executable (setup.exe, RanorexX.Y.Z.exe), but please check the list of installed programs in the Windows Control Panel.

Regards,
Johannes
.
Image