recorded test isn't running while remote connection...

Ask general questions here.
cld2403
Posts: 6
Joined: Thu Mar 10, 2011 9:50 am

recorded test isn't running while remote connection...

Post by cld2403 » Fri Mar 11, 2011 9:18 am

... recorded test isn't running while remote connection is closed

hey,
my recorded tests should run on a virtual server.
I connect to the server via a remote connection, than I recorded test cases and I want that the records are run on the server without having my pc on. When I close the remote connection the recorded test isn't running any more because it has no "picture" - my desktop isn't available.

That's a problem did anyone knows a solution? Or is it not possible to run the records without a monitor?

thanks in advance
regards

User avatar
artur_gadomski
Posts: 207
Joined: Mon Jul 19, 2010 6:55 am
Location: Copenhagen, Denmark
Contact:

Re: recorded test isn't running while remote connection...

Post by artur_gadomski » Fri Mar 11, 2011 9:40 am

Short answer No. long answer Noooo... ;)
You need to have a display for Ranorex to work on. RemoteDesktop locks the screen when you close it so you can't use it. There are other programs to connect to remote machine that don't lock the screen. I don't use them but I know people here do and they'll probably tell you which ones in a moment. If your virutal machine is a Hyper-V I found that using Connect from hyper-V manager doesn't close the display and works very well with Ranorex.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: recorded test isn't running while remote connection...

Post by Support Team » Fri Mar 11, 2011 9:53 am

Please, also see the following forum thread that discusses this topic in depth:
http://www.ranorex.com/forum/running-au ... t1295.html

Regards,
Alex
Ranorex Team
.
Image