Recorder fails under XP SP2 but works fine under XP embedded

Ranorex Spy, Recorder, and Studio.
fritzel
Posts: 3
Joined: Thu Jul 05, 2007 4:18 pm

Recorder fails under XP SP2 but works fine under XP embedded

Post by fritzel » Thu Jul 05, 2007 4:30 pm

Downloaded the demo package today. Install worked fine. Spy works, sample scripts work but the recorder refuses to start under XP SP2.
Getting error message: "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix the problem."
Reinstalled twice but no fix.

For a try I simply copied the installed directory tree to a USB stick and started under a far less potent machine running XP embedded. There the recorder works nicely.

Any ideas ?

Regards,

Fritzel

admin
Site Admin
Site Admin
Posts: 350
Joined: Wed Jul 05, 2006 7:44 pm

Post by admin » Thu Jul 05, 2007 10:20 pm

This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix the problem.
The Recorder needs some C++ runtime libraries.
Please install the Visual C++ Redistributable Package (VCRedist_x86.exe) if you get this error.
This package is 2.6 MByte and will install some Visual C++ libraries on your machine.
It can be downloaded from the Microsoft download site:

Microsoft Visual C++ 2005 Redistributable Package (x86)

Jenö
Ranorex Team

fritzel
Posts: 3
Joined: Thu Jul 05, 2007 4:18 pm

Working

Post by fritzel » Fri Jul 06, 2007 7:30 am

Working, thanks for the hint. You might want to add this to the install instructions for others.

Thanks Fritz.

admin
Site Admin
Site Admin
Posts: 350
Joined: Wed Jul 05, 2006 7:44 pm

Post by admin » Sun Jul 08, 2007 9:15 pm

You might want to add this to the install instructions for others.
Thank you for the suggestion, we extended the documentation with this info.

Jenö
Ranorex team