Reference Assemblies for framework not found

Ask general questions here.
paulgabion
Posts: 5
Joined: Fri Jul 12, 2013 9:24 pm

Reference Assemblies for framework not found

Post by paulgabion » Fri Jul 12, 2013 9:29 pm

Hello Ranorex Team,

Good afternoon!

I'm encountering the following warning while trying to compile a Ranorex solution on my machine that was originally made from another machine:

"The reference assemblies for framework ".NETFramework,Version=v4.0" were not found. To resolve this, install the SDK or Targeting Pack for this framework version or retarget your application to a version of the framework for which you have the SDK or Targeting Pack installed. Note that assemblies will be resolved from the Global Assembly Cache (GAC) and will be used in place of reference assemblies. Therefore your assembly may not be correctly targeted for the framework you intend. (MSB3644)
Some details:
1. The project was imported from another computer
2. The Ranorex app is installed in another drive different than C drive
3. The framework 4.0 is installed in C drive
4. The imported project is already version .NET 4.0

How can I fix this issue? Should I just download and install the installer found in that page?

My Ranorex version installed on my machine is 4.0.4
My .NET Framework is already .NET 4.0

Thanks!

Best Regards,
Paul

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Reference Assemblies for framework not found

Post by Support Team » Tue Jul 16, 2013 4:52 pm

Hi,

In order to analyze this issue could you please answer the following questions?
Is the full/extended version of the .Net 4.0 framework installed on your machine?
Which file was used to install Ranorex, the setup.exe, the Ranorex.X.exe or the Ranorex.X.msi one?
Do you have already tried to install the SDK?

Thanks,
Markus
.
Image