Remote agent using wrong working directory for referenced module

Ranorex Spy, Recorder, and Studio.
karltinsly
Posts: 27
Joined: Tue Jun 07, 2016 9:59 pm

Remote agent using wrong working directory for referenced module

Post by karltinsly » Thu Feb 27, 2020 3:54 pm

We have a solution that has a reference to another solution. The other solution looks up a password from a password keeper app. The password database is on a network drive. The password lookup works fine if run on my local machine, or if run through ranorex studio on the remote computer, but if I try and run it using a remote agent, it fails because it is trying to open the password database from c:\windows instead of the networked drive. The network drive location is specified in a parameter in the password lookup solution.

Why is the remote agent looking in the wrong working directory for the password lookup?

karltinsly
Posts: 27
Joined: Tue Jun 07, 2016 9:59 pm

Re: Remote agent using wrong working directory for referenced module

Post by karltinsly » Thu Feb 27, 2020 11:00 pm

I have passed this issue directly to support.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6181
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Remote agent using wrong working directory for referenced module

Post by odklizec » Fri Feb 28, 2020 10:27 am

Hi,

A first problem is, that Ranorex does not reccommned or support automation with network drives. This is something you should really avoid.

At next, from you description is not entirely clear, how exactly do you access the app you mentioned? Could you please share, at very least, screenshot from recording table where you access the app? Eventually, post the code if you are using code-based approach. Thanks.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration