Remote execution with multiple Test Suites

Experiences, small talk, and other automation gossip.
Broadnick
Posts: 29
Joined: Tue Nov 04, 2014 4:18 pm

Remote execution with multiple Test Suites

Post by Broadnick » Wed Sep 26, 2018 7:02 pm

I noticed the following problem: When a project has multiple test suites, remote execution does not work if the name of the original test suite has been changed.

For example, if my original test suite was named WEB_REC.rxtst and I rename it WEB_REC_Fr.rxtst, then the remote execution returns the message "No Test Suite Found ...". If I remove the _Fr and return to the original name, the execution works.

I search in the forum but I didn't find nothing about that problem... Is this a known issue?
Attachments
image1.jpg
image1.jpg (115.05 KiB) Viewed 118 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Remote execution with multiple Test Suites

Post by odklizec » Thu Sep 27, 2018 7:56 am

Hi,

Have you tried to rebuild the solution? I mean, do the clean build, eventually, manually delete entire bin folder and rebuild the solution. Only after that run the test remotely. If this does not help, I would suggest to search all traces of "WEB_REC", using an external text editor (e.g. notepad++) and simply replace all found places with new name. But I think simple solution "rebuild" should fix the issue?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration