Repo change when upgrade to 3.0 ver

Ask general questions here.
syuhada
Posts: 28
Joined: Mon Sep 20, 2010 7:56 am

Repo change when upgrade to 3.0 ver

Post by syuhada » Mon Aug 15, 2011 9:16 am

Hi Guys,

i have upgraded my solution file from 2.3.9 to 3.0. When i try to play the recording ,it failed.
I check my repo using Ranorex spy and I see the repo is different compare to my old repo(2.3.9).

Below is two example of the repo:


2.3.9 ver: form/element/container/toolbar[@accessiblename='Flow Control']/button[@accessiblename='If..Else']
3.0 ver: form/element/container/container/container/toolbar[@accessiblename='Flow Control']/button[@accessiblename='If..Else']

2.3.9 ver: element/form/element/element/list/listitem[@accessiblename='Scenario Manager']
3.0 ver: element/form/Container/element/list/listitem[@accessiblename='Scenario Manager']

Is there any way to solve this problem?


Thank you ;)

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Repo change when upgrade to 3.0 ver

Post by Support Team » Mon Aug 15, 2011 1:07 pm

Hi,
syuhada wrote:Is there any way to solve this problem?
Since 3.0 was a Major release, it had a few breaking changes. In most cases you have to do nothing, but in a few cases you have to adapt your RxPath. Did you follow the User Guide to migrate you Projects?
http://www.ranorex.com/support/user-gui ... uites.html

If not please take a look to the link above. And here are the breaking changes, which are in 3.0.
http://www.ranorex.com/support/user-gui ... html#c3338

BTW, the 3.0 RanoreXPaths you posted look "better" than the 2.X paths. If I had to guess, you are automating a .NET 4.0 application - could that be the case?

Regards,
Peter
Ranorex Team
.
Image