Report: "Data file or transformation file is missing"

Ask general questions here.
kmck
Certified Professional
Certified Professional
Posts: 83
Joined: Fri Jul 12, 2013 2:41 pm

Report: "Data file or transformation file is missing"

Post by kmck » Mon Nov 03, 2014 9:34 pm

Hello,

I just ran an 8 hour test and the report is refusing to open. I get the following error when opening:

Data file (Groups_20141103_095338.rxlog.data) or transformation file is missing.

However, this file, as well as the report file, are both present in the /bin/Debug folder as well as the /Reports folder (image attached).

Any idea why this would be giving this error and how I can rectify it so I won't have to re-run the test completely?

Thanks!
Attachments
RanorexReportFile.JPG
RanorexReportFile.JPG (40.25 KiB) Viewed 1457 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3908
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Report: "Data file or transformation file is missing"

Post by odklizec » Mon Nov 03, 2014 10:28 pm

Hi,
My guess is that the data file is somehow corrupted? Did your AUT terminated OK (without crash or forcible termination)? Could you check the AUT directory for the availability of *.rxlog.data_tmp file? If you find such file, try to rename it to *.rxlog.data and try to open the report again.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

kmck
Certified Professional
Certified Professional
Posts: 83
Joined: Fri Jul 12, 2013 2:41 pm

Re: Report: "Data file or transformation file is missing"

Post by kmck » Mon Nov 03, 2014 10:33 pm

Hey odklizec,

The AUT terminated fine and ran through the entire test suite without a forced termination. I didn't find the data_tmp file, which is what I thought would have been the issue initially. If it IS a corrupted file, I wonder what would cause it to become corrupt?

kmck
Certified Professional
Certified Professional
Posts: 83
Joined: Fri Jul 12, 2013 2:41 pm

Re: Report: "Data file or transformation file is missing"

Post by kmck » Tue Nov 04, 2014 2:03 pm

I ran the full suite again last night and received the same error. Any help or insight from Ranorex on this issue?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3908
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Report: "Data file or transformation file is missing"

Post by odklizec » Tue Nov 04, 2014 2:32 pm

It's hard to say what's wrong without examining the file. I would suggest you to send the report file to Ranorex support so they can look at it and decide what's wrong.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

mrollins
Posts: 10
Joined: Wed Aug 28, 2013 6:35 pm

Re: Report: "Data file or transformation file is missing"

Post by mrollins » Thu Nov 13, 2014 7:47 pm

From the looks of the screenshot Windows Explorer is hiding file extensions, so the extension there probably isn't actually ".rxlog.data", it's actually ".rxlog.data.<something>"

You should turn off "Hide extensions for known file types" in the explorer folder options to get the full path.

I used to have a similar problem with missing data files when I created a script with the same filename as the AUT. When I then tried to kill the AUT in my teardown I carelessly ended up killing my own script just before it finished. I had to first check that the PID I was trying to kill didn't match the current process PID (i.e. my script). :oops:
Michael Rollins