Report not getting saved in custom location

Class library usage, coding and language questions.
deepak1920
Posts: 19
Joined: Sat Feb 13, 2016 5:04 pm

Report not getting saved in custom location

Post by deepak1920 » Thu May 26, 2016 7:27 am

Hi,

I am trying to set up the report from Visual Studio. I have written below line of code -

Ranorex.Core.Reporting.TestReport.Setup(ReportLevel.Debug, "abc.rxlog", true, "C:\\Temp");

I have placed view.rxlog file in "C:\\Temp" folder. Now when I execute my script from Visual Studio, it creates abc.rxlog.data_tmp and abc.ref files in bin directory instead of "C:\\Temp". Apart from this abc.rxlog is not found anywhere.

Could you please help me in setting up my report. I want to save it to a specific location rather than bin directory.


Thanks!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Report not getting saved in custom location

Post by Support Team » Mon May 30, 2016 3:23 pm

Hi deepak,

In order to save your report to your custom location, you need to add the path to the filename-argument.
Furthermore, the report needs to be saved at the end of the test.
Ranorex.Core.Reporting.TestReport.Setup(Ranorex.ReportLevel.Info,@"C:\Temp\abc.rxlog",true);
Ranorex.Core.Reporting.TestReport.SaveReport();
The path you are using as an argument, only points to an already existing custom template, in order to change appearance of your report.

I hope this information helps you.

Sincerely,
Matthias
.
Image