Reporting a screenshot of a data driven adapter

Ask general questions here.
andy.simpson
Posts: 6
Joined: Fri Jun 22, 2018 8:59 am

Reporting a screenshot of a data driven adapter

Post by andy.simpson » Wed Feb 27, 2019 5:30 pm

Hi,

I have a test which runs through 47 iterations of an excel spreadsheet, each row of the spreadsheet is bound to a separate repository item so interrogates a different object with each run. Id like to report a screenshot of the specific item that's being interrogated to help with troubleshooting. I have managed to do it with the below by having a code module with the variable path passed in as an adapter (in this case FieldToBeValidated) and then simply had
Report.Screenshot(FieldToBeValidated);
at the end of my code module.

This appears to work great for the first iteration but the same screenshot shows for every iteration even when the adapter path is changing. I've attached some screenshots of the code module, the first test run where its working as expected and the second where its pulling in the first tests image incorrectly

I cant understand why this would happen apart from maybe some caching issue, the repository paths are definitely correct and this is the case across 50 odd iterations

and help would be appreciated
Attachments
ranorex form.png
ranorex form.png (26.45 KiB) Viewed 38 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4421
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Reporting a screenshot of a data driven adapter

Post by odklizec » Thu Feb 28, 2019 9:19 am

Hi,

This definitely sounds like caching issue. Have you tried to disable cache for given repo element or rooted folder?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration