Reporting Ranorex Exception

Bug reports.
JoeR
Posts: 32
Joined: Fri Dec 03, 2010 6:15 pm
Location: Morrisville, NC
Contact:

Reporting Ranorex Exception

Post by JoeR » Fri Feb 04, 2011 8:18 pm

Ranorex Studio Version : 2.3.8.10854
.NET Version : 2.0.50727.4952
OS Version : Microsoft Windows NT 6.1.7600.0
Current culture : English (United States) (en-US)
Running under WOW6432, processor architecture: AMD64
Working Set Memory : 158784kb
GC Heap Memory : 37478kb

Exception thrown:
System.NullReferenceException: Object reference not set to an instance of an object.
at Ranorex.Controls.ItemRecorder.UpdateListFromRecordTable(Boolean causeOnRecordingChanged)
at Ranorex.Controls.ItemRecorder.OnSetRecordTable(RecordTable value)
at Ranorex.Controls.ItemRecorder.set_CurrentRecordTable(RecordTable value)
at Ranorex.Controls.ItemRecorder.get_CurrentRecordTable()
at Ranorex.Controls.ItemRecorder.get_CurrentRepository()
at Ranorex.Addins.RecorderControl.<>c__DisplayClass2.<itemRecorder_SelectedItemsChanged>b__0()

---- Recent log messages:
Failed to append recent log messages.
System.InvalidOperationException: Sequence contains no elements
at System.Linq.Enumerable.Single[TSource](IEnumerable`1 source)
at ICSharpCode.SharpDevelop.Sda.LogMessageRecorder.AppendRecentLogMessages(StringBuilder sb, ILog log)
at ICSharpCode.SharpDevelop.Sda.ExceptionBox.getClipboardString()

---- Post-error application state information:
Installed 3rd party AddIns: [RxLogViewer 2.3.8.10854], [RxObjectRepository 2.3.8.10854], [RxRecorder 2.3.8.10854], [Workflow Foundation Designer 2.3.8.10854], [ElementTree 2.3.8.10854]
Workbench.ActiveContent: [TextEditorDisplayBindingWrapper C:\Users\jruss\Documents\RanorexStudio Projects\BuildLinks Automation\Execution\Program.cs]
ProjectService.OpenSolution: [Solution: FileName=C:\Users\jruss\Documents\RanorexStudio Projects\BuildLinks Automation\BuildLinks Automation.rxsln, HasProjects=True, ReadOnly=False]
ProjectService.CurrentProject: [CSharpProject: Execution]

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Reporting Ranorex Exception

Post by Support Team » Mon Feb 07, 2011 11:02 am

Hi,

Thank your for posting the bug. We tried to reproduce this error but we had no success. Would it be possible to post us a short description how we can reproduce this null reference? Even better would be a short example project to reproduce the problem.

Thanks in advance.

Regards,
Peter
Ranorex Team
.
Image