ReportToPDF causes an error "sometimes"

Ranorex Spy, Recorder, and Studio.
dmconsulting1
Posts: 91
Joined: Fri Nov 08, 2019 3:23 pm

ReportToPDF causes an error "sometimes"

Post by dmconsulting1 » Wed Jul 01, 2020 2:18 pm

So I have the build validation test running off TFS. I had 3 builds yesterday that reported a failure to TFS when there was no failure. The PDF gets generated, but something in the routine causes an error.

Looking at the build, it says the test run failed, but the PDF shows as passed.

2020-06-30T19:21:24.5026193Z Execute test suite
2020-06-30T19:21:24.5026193Z Test execution failed
2020-06-30T19:21:24.5026193Z Report: C:\agent2\_work\85\s\dev-packages\Ranorex.P38.1.0.5-ci-20200612164129\TestExecutable\Reports\BuildValidation_1_3_20200630_121526.rxzlog
2020-06-30T19:21:24.5026193Z Report: C:\agent2\_work\85\s\dev-packages\Ranorex.P38.1.0.5-ci-20200612164129\TestExecutable\Reports\BuildValidation_1_3_20200630_121526.rxlog.junit.xml
2020-06-30T19:21:24.5026193Z Job completed: Error
2020-06-30T19:21:25.6393817Z ##[error]Process completed with exit code -1.
2020-06-30T19:21:25.6413349Z ##[debug]System.Exception: Process completed with exit code -1.
at Microsoft.VisualStudio.Services.Agent.Worker.Handlers.PowerShellExeHandler.<RunAsync>d__13.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Microsoft.VisualStudio.Services.Agent.Worker.TaskRunner.<RunAsync>d__24.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Microsoft.VisualStudio.Services.Agent.Worker.StepsRunner.<RunStepAsync>d__1.MoveNext()
2020-06-30T19:21:25.6413349Z ##[section]Finishing: Run Ranorex


I have attached the log referenced (BuildValidation_1_3_20200630_121526.rxzlog), it doesn't do it every time, just when someone isn't looking it seems. :lol:

I don't see why it thinks there is a failure. Maybe we need to update the automation helpers?
Attachments
BuildValidation_1_3_20200630_121526.zip
(256.39 KiB) Downloaded 2 times

User avatar
RobinHood42
Posts: 324
Joined: Fri Jan 09, 2015 3:24 pm

Re: ReportToPDF causes an error "sometimes"

Post by RobinHood42 » Mon Jul 13, 2020 8:20 am

Hi,

Updating the automation helpers and, especially, the ReportToPDF tool is for sure a good idea. Just give it a try!

Best,
Robin

dmconsulting1
Posts: 91
Joined: Fri Nov 08, 2019 3:23 pm

Re: ReportToPDF causes an error "sometimes"

Post by dmconsulting1 » Thu Jul 16, 2020 6:23 pm

Updating the Helpers, hope for the best.