Repository and source control

Ask general questions here.
User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Repository and source control

Post by Support Team » Thu Dec 06, 2012 11:41 am

Hello,

Could you please update Ranorex to version 4.0.0?
Our current version supports 'Team Foundation Server' as shown in our 'Release Notes'.

Regards,
Markus (T)
.
Image

UgaAga
Posts: 69
Joined: Thu Mar 15, 2012 2:11 pm

Re: Repository and source control

Post by UgaAga » Thu Dec 06, 2012 1:24 pm

Hi,
thanks for the info. Seems that there are many changes. Sadly i can't compile anymore one of my projects. It uses com references. I get this error
Namespace or type specified in the Imports 'CWUIControlsLib' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases. (BC40056)

The library worked before, contains of course public members and i don't use aliases. I can compile in visual studio easily.

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Repository and source control

Post by Support Team » Thu Dec 06, 2012 4:39 pm

Hello,

In order to fix issues with references you could delete your reference to 'CWUIControlsLib' and add it again.
Have you installed Ranorex 4.0 with setup.exe?

Regards,
Markus (T)
.
Image

UgaAga
Posts: 69
Joined: Thu Mar 15, 2012 2:11 pm

Re: Repository and source control

Post by UgaAga » Thu Dec 06, 2012 4:52 pm

Hey,
thanks for the answer. I used the Ranorex-4.0.0.exe. I removed and added the reference but the error is still there.

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Repository and source control

Post by Support Team » Thu Dec 06, 2012 5:20 pm

Hi,

Could you try to reinstall it with the setup.exe file?
This will ensure that all prerequisites will be automatically installed too.
If this shouldn't solve the issue, it would be great if you could send your solution and the specific library to our support email address [email protected], this will allow us to analyze the issue in detail.

Thanks,
Markus
.
Image

UgaAga
Posts: 69
Joined: Thu Mar 15, 2012 2:11 pm

Re: Repository and source control

Post by UgaAga » Fri Dec 07, 2012 10:52 am

Hi,
sorry but the setup.exe doesn't work either.
You can easily analyze the com issue by adding a com reference to the project and use it in a class module (with using xxx; in the header). You will get an error.

Thanks a lot

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Repository and source control

Post by Support Team » Fri Dec 07, 2012 12:55 pm

Hi,

I talked with the responsible developer about this issue and we found out that this is unfortunately a bug with the new Ranorex version.
We are very sorry for that and we will fix this issue as soon as possible!
As current workaround you could open your Solution with VS and rebuild it. After the build you have to copy the generated "Interop.*.dll" (COM ref) to, for instance, the root folder of your Ranorex Solution.
Now you have to open your Solution with Ranorex Studio again, delete the reference to the COM assembly and add a reference to the copied "Interop.*.dll", this should work as a current workaround.

Regards,
Markus
.
Image

UgaAga
Posts: 69
Joined: Thu Mar 15, 2012 2:11 pm

Re: Repository and source control

Post by UgaAga » Fri Dec 07, 2012 2:59 pm

Thanks a lot!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Repository and source control

Post by Support Team » Mon Dec 10, 2012 11:38 am

Hi,

You're welcome :).

Regards,
Markus
.
Image