Repository.RepoItemInfo Not Able To Change SearchTimeout?

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
bradj
Posts: 8
Joined: Wed Mar 13, 2013 6:56 pm

Repository.RepoItemInfo Not Able To Change SearchTimeout?

Post by bradj » Wed May 22, 2013 9:36 pm

Hi-

I'm trying to dynamically change the searchtimeout property of the Ranorex.Core.Repository.RepoItemInfo class. However, no matter what I set it to it seems to still use the timeout defined when I created the item in the repository. If I change it manually in the repo, it will use that value.
sfdcRepo.TemplateEditor.CreateDocFromTemplateButtonInfo.SearchTimeout = 1000;	
bool res = sfdcRepo.TemplateEditor.CreateDocFromTemplateButtonInfo.Exists();
When I make the above call, it tries for 30 seconds for the item to exist. I would expect waiting only 1 second.

Any ideas?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Repository.RepoItemInfo Not Able To Change SearchTimeout?

Post by Support Team » Fri May 24, 2013 12:38 pm

Hi,

Just one initial question, which Ranorex version are you using?
The current one (4.0.3)?

Thanks,
Markus
.
Image

bradj
Posts: 8
Joined: Wed Mar 13, 2013 6:56 pm

Re: Repository.RepoItemInfo Not Able To Change SearchTimeout?

Post by bradj » Fri May 24, 2013 2:15 pm

Yes. 4.0.3.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Repository.RepoItemInfo Not Able To Change SearchTimeout?

Post by Support Team » Mon May 27, 2013 2:39 pm

Hi,

This should work with 4.0.4. Please install this version.

Regards,
Markus
.
Image

bradj
Posts: 8
Joined: Wed Mar 13, 2013 6:56 pm

Re: Repository.RepoItemInfo Not Able To Change SearchTimeout?

Post by bradj » Tue May 28, 2013 4:37 pm

Tried with 4.0.4 and still doesn't work. Code example below of how I tested:

Code: Select all

sfdcRepo.MainPage.Header.NavBar.TemplatesTabInfo.SearchTimeout = 1000;
if (!sfdcRepo.MainPage.Header.NavBar.TemplatesTabInfo.Exists())
{
}
When the code hits the Exists() function, it takes 30 seconds to return false. I would have expected it to only try for 1 second since I set the SearchTimeout to 1000 milliseconds.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Repository.RepoItemInfo Not Able To Change SearchTimeout?

Post by Support Team » Wed May 29, 2013 11:00 am

Hi,

This is because Ranorex at first searches for the root element which is in your case "sfdcRepo.MainPage" and this is the reason why the search timeout of that repo item is used.
It would work if all parent elements "MainPage.Header.NavBar" would exist since you just changed the search timeout for the "TemplatesTabInfo" element.

Regards,
Markus
.
Image

bradj
Posts: 8
Joined: Wed Mar 13, 2013 6:56 pm

Re: Repository.RepoItemInfo Not Able To Change SearchTimeout?

Post by bradj » Wed May 29, 2013 10:04 pm

Not sure I follow. I tried setting the root element timeout and it still takes the default 30 seconds. Do I have to set EVERY search timeout and every level from root to the element I am looking for in order for this to work? That doesn't seem logical.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Repository.RepoItemInfo Not Able To Change SearchTimeout?

Post by Support Team » Fri May 31, 2013 2:55 pm

Hello,

Please check the search timeout setting in each layer in your repository. Please take a look at the last post in the following forum thread "Global Delay needed".
Are there any folders in your repository structure?
Please take a look at the section "Repository Settings Dialog" in our user guide in order to get more information about the default settings for the repository.

Regards,
Bernhard
.
Image