[Rnx 6.0] Steps won't execute

Bug reports.
KeoRobb
Posts: 1
Joined: Fri Sep 13, 2019 10:30 am

[Rnx 6.0] Steps won't execute

Post by KeoRobb » Fri Sep 13, 2019 1:28 pm

Hi everyone !

I am a new user on Ranorex, I worked on Test automation for 3 months now, and I'm experiencing a problem that never happened to me before. Please note that my version of Ranorex is outdated but the company I work in don't plan on getting a new license for us to update the software. It means that I'm stuck with Ranorex 6, with no possibility to update unfortunatly.

So I made a solution which purpose is to install some software to check that there's no regression on them. To explain everything for your understanding, we have a script that build new installation exe files each night. We gather the paths for all the files using XML file, then we send them to Ranorex by parsing the XML file, for it to open the right installer. After this, we want to use Keystroke or Keysequence to navigate in the installer until the setup is done.
This solution is launched every night with Jenkins, using a Windows 7 x32 Japanese VM (the Host machine is a Win10 x64 French).

The problem lies in the execution of the test suite along with Jenkins. When the solution is launched locally on the same VM used every night, every test are executed correctly with a 100% success rate. However, when using Jenkins to launch those tests every thing goes well until the first KeyStroke step.

The architecture of the test is as this :
-Run Application (soft is named RGPA)
-Delay of 5s
-WaitForExist "RGPA auto-extraction"
-Delay of 5s
-Press "Y" (KeyStroke method) with focus on RGPA auto-extraction item (I tried without the focus, and with the focus on the "Yes" button)
-WaitForNotExist "RGPA auto-extraction"
...

What happen is that the software launches as intended, the WaitForExist step is working so Rnx find the correct item, but after the 5s Delay, Keystroke happens but it has no effect on the installler. The WaitForNotExist step will then make the test goes to failure, because the window still exist (because the "Y" key haven't been used).
When I launch this test in local everything goes well, as I said, so I though of 2 potential problems : for me, either Ranorex is going too fast for the VM and so the button is "unavailable", or it's Jenkins that messes everything up.

What are your though about this ? Any workaround to make it work ? Maybe a known issue ?

Sorry if my english isn't really good, this is not my native language.
Best regards,
Robb.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5071
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: [Rnx 6.0] Steps won't execute

Post by odklizec » Mon Sep 16, 2019 9:10 am

Hi Robb,

I'm afraid, with such old Rx version, there is very little chance anyone here can suggest something meaningful. If you cannot update to most recent Ranorex version, then make sure you have installed, at very least, the last Rx version, covered by your expired license. Aside of installing last available Rx version, all I can suggest is to try toggling the option Asynchronous dispatching mouse and keyboard events (found in Settings >> Advanced tab). Simply, try to switch it to the opposite state, than you have it now. Another thing you might try, is to enable or disable Turbo mode in the particular recording module, in which your test fails. And finally, are you sure the solution started with Jenkins uses the same Ranorex Settings as the solution started locally? This was the most common reason of similar failures in the past (before Ranorex started storing its settings within the solution).
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration