Robust RanoreXpath

Ask general questions here.
User avatar
Julien Diot
Posts: 52
Joined: Wed Feb 20, 2019 4:25 pm
Location: Amiens (FR)

Robust RanoreXpath

Post by Julien Diot » Wed Mar 03, 2021 8:48 am

Hello,

I have just tried the new "Robust RanoreXpath" feature on one of my applications developed in DELPHI, but now I'm getting errors that aren't there.

On a TMaskEdit component, it tells me that the text property was not found while I just do a "Click" action and then a "KeySequence" action on it.
Error :
"Item 'RepositoryEvolucareIntensive.EvolucareAuthentication.PasswordChange.DLG_Content.PasswordEdit1' is no Text.
The element does not support the required capability 'text'. "

Another question, on items previously added in the repository, the "RobustPath" property is not set. Is this a problem?

Thank you
Attachments
Snapshot.rxsnp
(66.54 KiB) Downloaded 9 times

User avatar
vseaver
Certified Professional
Certified Professional
Posts: 16
Joined: Tue Jan 19, 2021 5:24 pm
Location: Colorado, US

Re: Robust RanoreXpath

Post by vseaver » Thu Mar 25, 2021 5:42 pm

Hi Julien,

It is expected behavior that the robust path is not retroactively set on repository items that were already there. That is the way all of the defaults work. New repository items will have the robust setting added.

As far as you no longer being able to enter text into your TMaskEdit component.

Have you tried building the test with robust mode off, and does it work?

If yes, it sounds like it may be a bug. Have you submitted a ticket to support yet?
Sales Engineer @ Ranorex