Run tests for iOS app. No app started event

Mobile Testing, Android App Testing.
dancar
Posts: 1
Joined: Tue Aug 11, 2015 3:44 pm

Run tests for iOS app. No app started event

Post by dancar » Tue Aug 11, 2015 4:04 pm

Hello,

I have an iOS-app that I've successfully instrumented and deployed to my ipad.
I have then created a couple of test-cases containing some recordings of basic navigation throughout the app.

My problem is that the tests sometimes never start and I get a timeout because the 'app started' event is never received. I've made sure that there is no instance of my app running before I try to run the test, but that doesn't seem to matter.

I've also increased the timeout-time to 40 seconds, without any success.

One thing I noticed was that the tests were more likely to succeed when I restarted the the RxServiceApp on the device.

But the tests still sometimes timeouts when waiting for the 'app started' event.
If the tests never return the same results then I can't use them.


Any ideas on what I should do? Thanks in advance!

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Run tests for iOS app. No app started event

Post by krstcs » Tue Aug 11, 2015 5:12 pm

Welcome to the forums!

First, let me say that I don't work on mobile devices, so I'm not going to be able to help on that end.

Second, when raising an issue on the forums, please always include the following information so we can all be on the same page and avoid misunderstandings and delays:

1. Ranorex version (5.4.0 is current, 5.3.3 is last previous, and those are the only ones supported)
2. Windows version
3. Technology of system-under-test (SUT) (In your case it is an iOS app, but it could be Java, Flash/Flex, etc.)
4. Full and exact text of any errors.
5. RanoreXPath of any elements in question.
6. Ranorex Snapshot (not a screenshot) of any elements in question.
7. User-code, if applicable.
8. Either the Ranorex solution you are having issues with, or a sample solution that demonstrates the issue, if you can't release the actual solution.

Also, if you can't post or dont' feel comfortable posting this information to the forums, you can directly email Ranorex's support team at [email protected]. They are usually much faster at answering email queries because they like to let the community have first shot at the forums so we can all learn.
Shortcuts usually aren't...