running selected items, runs all items in recording

Ranorex Spy, Recorder, and Studio.
zivshapirawork
Posts: 62
Joined: Wed Sep 24, 2014 7:47 am
Location: Israel

running selected items, runs all items in recording

Post by zivshapirawork » Sun Oct 30, 2016 7:00 am

hi

when I mark specific items in a recording and select from the menu "run selected items", actually all items in the recording are executed from the start.

Ranorex 6.1.0

I think this started in previous versions.

jma
Posts: 111
Joined: Fri Jul 03, 2015 9:18 am

Re: running selected items, runs all items in recording

Post by jma » Wed Nov 02, 2016 3:41 pm

Hi zivshapirawork,

I couldn't reproduce this issue with the latest version of Ranorex. Could you try updating to the latest version, 6.1.1, and check if this resolves the issue?

armstronghm24
Posts: 38
Joined: Tue Dec 20, 2016 10:16 pm

Re: running selected items, runs all items in recording

Post by armstronghm24 » Thu Nov 09, 2017 6:29 pm

I am running into the same issue. I have 7.0.0 installed.

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: running selected items, runs all items in recording

Post by krstcs » Fri Nov 10, 2017 2:47 pm

I don't have this issue with Ranorex 7.2.1, and I didn't have it with 7.0.X or 7.1.X either.

My guess would be that it's a bad installation. Try a clean re-install:
1. Uninstall Ranorex
2. Reboot
3. Re-install Ranorex using Ranorex-7.2.1.exe
Shortcuts usually aren't...