Screenshot-Problems and Questions

Ask general questions here.
ArminSeidling
Posts: 4
Joined: Thu Sep 05, 2013 1:41 pm

Screenshot-Problems and Questions

Post by ArminSeidling » Fri Sep 06, 2013 6:30 am

Hey Guys,

i wrote a little c# code for an android phone to switch through the sites and screenshoted these actions...
Report.Screenshot();
This function was used to take the screenshots, i don't know if there is a better way to make screenshots.

But here is the main-problem:
If this test runs it make the normal and expected screenshots and the report is perfect.
But the screenshots are saved sometimes in the Debug folder himself and sometimes it generates an own folder for the screens... how this happens?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Screenshot-Problems and Questions

Post by Support Team » Mon Sep 09, 2013 3:25 pm

Hello,

Are you executing the test using the "PLAY" button in the recorder, or do you use the "PLAY" button in the Test Suite?
If a recording is executed using the "PLAY" button in the recorder, the images will be saved in the output folder directly, but if you execute the whole Test Suite, the images are created in an own folder.
I will make an entry in our bug tracking system and we will discuss this issue internally.
Thank you!

Regards,
Bernhard
.
Image

ArminSeidling
Posts: 4
Joined: Thu Sep 05, 2013 1:41 pm

Re: Screenshot-Problems and Questions

Post by ArminSeidling » Tue Sep 10, 2013 1:13 pm

Hey,

thanks for your efforts. I recogniced it and optimized my code for this issue. Thanks.

Regars,
Armin.