Screenshots in Ranorex Report Viewer are not shown properly

Bug reports.
slw
Posts: 9
Joined: Mon Apr 15, 2013 6:32 pm

Screenshots in Ranorex Report Viewer are not shown properly

Post by slw » Mon Apr 15, 2013 6:52 pm

Dear Ranorex Team,

We upgraded Ranorex to version 4.0.3 today and since then screenshots in Ranorex Report Viewer are not shown properly: upper part of a screenshot is shown and lower part is not visible (see attachment below). It is also not possible to scroll down to see the full screenshot.
ranorex_4.0.3_report_problems.png
ranorex_4.0.3_report_problems.png (17.43 KiB) Viewed 1172 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Screenshots in Ranorex Report Viewer are not shown properly

Post by Support Team » Tue Apr 16, 2013 2:45 pm

Hello,

Thank you for reporting this issue.
Is it possible to expand the window of the "Ranorex Report Viewer" in order to view the whole screenshot?
How did you create the screenshot? Did you use the method "Report.Screenshot()" in the user code?
Is it possible to get the screenshot in order to analyze the issue in more detail?
Thank you!

Regards,
Bernhard
.
Image

slw
Posts: 9
Joined: Mon Apr 15, 2013 6:32 pm

Re: Screenshots in Ranorex Report Viewer are not shown properly

Post by slw » Tue Apr 16, 2013 3:29 pm

Hello,

* the problem exists in Ranorex Report Viewer as well as in Ranorex Studio itself when we click on the screenshot and it becomes active
* screenshot is created automatically in case of test error
* In case if the windows is maximized / windows size is changed, the screenshot is not resized => bottom part of the image is till not visible
* When the screenshot is active, scrolling does not scroll it
* I will send you a sample report per mail (to supportATranorex.com): just open the report and click on any screenshot. We are not able to see the lower part of a screenshot.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Screenshots in Ranorex Report Viewer are not shown properly

Post by Support Team » Thu Apr 18, 2013 4:49 pm

Hello,

Thank you for the report files you sent us.
I forwarded the issue to the responsible developer. He will analyze and fix the issue as soon as possible.

Regards,
Bernhard
.
Image

swmatisa
Posts: 122
Joined: Fri Aug 05, 2011 7:52 am

Re: Screenshots in Ranorex Report Viewer are not shown properly

Post by swmatisa » Wed Apr 24, 2013 11:40 am

Hello,

I have exactly the same problem. Did you found a workaround, because it is a real problem to "debug" my TestCase? Did you need other data to correct this bug?

Thanks for your help
SW

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Screenshots in Ranorex Report Viewer are not shown properly

Post by Support Team » Thu Apr 25, 2013 4:12 pm

Hello,

Our developers are working to fix this issue at the moment.
This issue will be fixed in our next release.
In the output directory should be a folder with the screenshots in it. Is it a workaround for you to open the screenshots directly?

Regards,
Bernhard
.
Image

swmatisa
Posts: 122
Joined: Fri Aug 05, 2011 7:52 am

Re: Screenshots in Ranorex Report Viewer are not shown properly

Post by swmatisa » Fri Apr 26, 2013 7:06 am

Hello,
Support Team wrote:In the output directory should be a folder with the screenshots in it. Is it a workaround for you to open the screenshots directly?
It is a little bit difficult with a lot of files.

My workaround: I create a VM with version 4.0.2 and open Ranorex Report Viewer with the old version.

Hope this helps
SW

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Screenshots in Ranorex Report Viewer are not shown properly

Post by Support Team » Mon Apr 29, 2013 3:32 pm

Hello,

Thank you for providing your workaround.

Regards,
Bernahrd
.
Image