Selenium Webdriver Server Connection Error

Ranorex Spy, Recorder, and Studio.
csolanki
Posts: 73
Joined: Thu Mar 22, 2018 8:51 am

Selenium Webdriver Server Connection Error

Post by csolanki » Mon Mar 26, 2018 11:37 am

Hi Team,
I have established Selenium server standalone connection 3.11.0 with Ranorex by passing host URL in end point. But I find every alternate second connection is getting an error, which is making test case to fail itself at first. What could be the solution for it ?
For more info, I am using Ranorex, 8.0.1 --chromedriver, 32 Bit --windows machine. Selenium Server - ChromeDriver is in same folder to take the path in.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Selenium Webdriver Server Connection Error

Post by Support Team » Wed Mar 28, 2018 9:39 pm

Hi csolanki,

It would be very helpful if you are able to provide the exact error you are getting. Knowing which error you are getting will greatly helpful in narrowing down the cause. If I had to guess based on your description, I would start by looking at your timeout settings in the Ranorex solution settings. To access this setting, please open your solution within Ranorex Studio. Next, open the settings page and go to the plugins tab. Here you will want to look for the WebDriver category:
wdSettings.png
wdSettings.png (30.71 KiB) Viewed 332 times
If you would like to learn more about the settings available in Ranorex Studio, please visit the below link:

https://www.ranorex.com/help/latest/ran ... s-overview

I hope this helps and I look forward to hearing from you!

-Jon
.
Image