Setting Value on Hidden Object - Urgent

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
carsonw
Posts: 178
Joined: Tue Nov 08, 2011 10:01 pm

Setting Value on Hidden Object - Urgent

Post by carsonw » Tue Sep 17, 2013 1:40 am

Looking for a response to this somewhat urgently...

Is there any kind of restriction for setting the value of a hidden object in ranorex?

In IE - I have a text field - and "behind it" I have a hidden password field. As a user, I can type my value in the text field, the value in the hidden field gets set and I'm good to go.

In ranorex, I must set the value for both the hidden and the text field (just setting the text field doesn't work, even with send keys)... however when I try to set the value in the hidden field, the value just remains null (no errors are returned by ranorex).

Is there something within Ranorex that would prevent this (i.e. it sees the field is hidden, and then does not set them value)?

Thanks!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Setting Value on Hidden Object - Urgent

Post by Support Team » Tue Sep 17, 2013 2:50 pm

Hi,

There is no "Ranorex restriction" but the control can restrict the access to the element in some way.

If I got this correctly you are "manually" (without the use of Ranorex) able to do the mentioned steps but when you try to perform the same with Ranorex the hidden field will not be automatically set, right?
Which Ranorex actions did you use in order to set the value of the text field?
Can we somehow get access to your application?
If not, could you post or send (to [email protected]) a snapshot file of these controls?

Thank you in advance!

Regards,
Markus
.
Image

carsonw
Posts: 178
Joined: Tue Nov 08, 2011 10:01 pm

Re: Setting Value on Hidden Object - Urgent

Post by carsonw » Tue Sep 17, 2013 10:22 pm

Hi Markus thanks so much for your speedy response, I really appreciate it!

Our developers were investigating changing our controls and since they are using a third party plug in finding a work around was not trivial. Before I pushed them too hard to do this, I wanted to ensure there wasn't something on the tool's side first.

I had to play with the application quite a bit to see what was happening, but was finally able to figure it out.

It is true that there was a text object and a placeholder object on the page. Having the two objects is what threw all of us.

What ended up happening was this: When you click on the text box object... at that moment that textbox object is destroyed, and a new objects comes into existence which is a proper password object box. But, the object is only there AFTER you interact with the first text box somehow.

So, by having our automation click the box, waiting a second, and then populating the password box (which is technically a different object), it worked.

To the user it's all seemless, but to automation we actually have two repository items - one for the text box where we perform the initial click to get the textbox object to be destroyed and a new password object to be created... and then the other which is the new password object that we can now set. Finally, we have to send the values as presskeys rather than setting them directly, or none of it works.

This was a first for me, and for most of us here. The objects only behave this way in IE <10 only (IE 8 & 9 specifically for us) so it was a bit baffling.

Anyway, mystery solved... thanks so much again for jumping right in :)

Carson.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Setting Value on Hidden Object - Urgent

Post by Support Team » Wed Sep 18, 2013 3:21 pm

Hi Carson,

You're welcome!
I am glad that you and your team were able to solve the issue :).
Thank you for the detailed description of your solution.

Regards,
Markus
.
Image