Slow when searching objects

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
danffie
Posts: 4
Joined: Sun Nov 03, 2013 11:00 pm

Slow when searching objects

Post by danffie » Sun Nov 24, 2013 2:04 pm

I've tried all the ways to accelerate the speed.
1. Turbo mode
2. Speed factor
3. Minimize the duration time, keyboard action time, mouse time and key sequence time.
4. Try to modify the XPath. (Don't know whether it is correct)
The RanoreXPath of our product is something like "/form/tabpagelist/tabpage/element/element/tree/treeitem/treeitem/treeitem/text[@automationid=xxx and @name=xxxx]"

But seems the speed cannot be improved. The 1st time to search objects of the product will take around 6 seconds and the following action will take around 2-6 seconds randomly.

Is there anyone who could help to check what is the problem and how we can resolve it? Thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Slow when searching objects

Post by Support Team » Tue Nov 26, 2013 4:13 pm

Hello danffie,

Which Ranorex version do you use?

Please post or send us ([email protected]) a Ranorex Snapshot of your application.
This would help us in analyzing your issue.
Please take a look at our User Guide for more information on how to create snapshot files.

Thanks in advance.

Regards,
Markus (T)
.
Image

mzperix
Posts: 137
Joined: Fri Apr 06, 2012 12:19 pm

Re: Slow when searching objects

Post by mzperix » Thu Mar 13, 2014 12:06 pm

Do you run your tests in Ranorex Studio?

If yes, try this last one: use the Run without debugger option to run your tests. Note, that you cannot play a recording file this way, only the whole test suite will be run.

Regards,
Zoltan