Snapshot not captured in the rxlog file

Ranorex Spy, Recorder, and Studio.
anujakulkarni
Posts: 29
Joined: Wed Jan 07, 2009 1:15 pm

Snapshot not captured in the rxlog file

Post by anujakulkarni » Thu Mar 05, 2009 12:18 pm

Hi,

I am capturing the snapshot of the dialog where my testcase fails using

Code: Select all

Report.Screenshot();
Unfortunately Ranorex cannot capture the screenshot for one of the dialogs. Instead it is capturing the screenshot of the dialog present behind this one, as if this dialog box is transparent!!

Following are the details of the UIAutomation section in the "Detail" tab as recorded by Ranorex Spy for this particular dialog.

- ClassName = Window
- ControlType = Window
- FrameworkId = WPF
- IsContentElement = True
- IsControlElement = True
- IsKeyboardFocusable = True
- IsPassword = False
- IsRequiredForForm = False
- LocalizedControlType = window

It was working perfectly initially. But now the window style for this dialog is set to "Null" as we did not want the typical windows border.

Please let me know if this is a known issue and if there is any resolution for the same?

Cheers,

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Thu Mar 05, 2009 3:26 pm

Its a known issue for "allowtransparency" forms in WPF.
It will be fixed in the next version of Ranorex 2.0

Regards,
Christian,
Ranorex Support Team

anujakulkarni
Posts: 29
Joined: Wed Jan 07, 2009 1:15 pm

Post by anujakulkarni » Mon Mar 09, 2009 12:17 pm

Hi Christian,

Thanks for the update.

Cheers,