Sporadic fail to find ui-items

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Max H.
Posts: 1
Joined: Wed Nov 06, 2013 5:13 pm

Sporadic fail to find ui-items

Post by Max H. » Thu Nov 07, 2013 11:39 am

Sometimes when our tests run in a VM (winXP VM on ESX, Ranorex 4.1.1) specific test(s) fail(s) to find a specific ui item(s) from our repository, which also not occur in the snapshots.

To illustrate the problem:
One would expect the following two snapshots made on the same VM with the same SUT-Software and Test-Software in two consecutive runs of the same test to be identical, but they are diffrent.
MissingItems.png
Snapshot that is missing the radio buttons we want to click
MissingItems.png (96.3 KiB) Viewed 782 times
ExpectedItems.png
Snapshot as we expected it to be (no missing Items)
ExpectedItems.png (116.1 KiB) Viewed 782 times
The Snapshot with the ExpectedItems was actually made in the previous run of the test, (not long) before the run of the Test that made the Snapshot that is missing Items. Other examples have the incomplete Snapshot in the first run and the complete snapshot in the second run. And while one can find patterns in the occurrance of the missing snapshot, lets just call it sporadic. (In the end the snapshot should never miss items)

The problem also occured on ranorex 3.3. From the user's point of view the elements looking fine and is working correctly. Only the automation is not finding the radio button which is a child of the list item.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Sporadic fail to find ui-items

Post by Support Team » Fri Nov 08, 2013 4:37 pm

Hello Max,

It looks like that you clicked on 'Enter' in Spy regarding your first snapshot.
The element tree shows only all predecessors of your ListItem in this case.
In comparison, the second snapshot shows the whole element tree of your application.

Could you please post your Ranorex Snapshot of your application?
Additionally, please post your report incl. the error message.
This would help us in analyzing your issue.
Please take a look at our User Guide for more information on how to create snapshot files.

Regards,
Markus (T)
.
Image