Spy does not always see Chrome browser's Dom WebDocument

Ranorex Spy, Recorder, and Studio.
lyn5000
Posts: 50
Joined: Mon Feb 13, 2012 5:52 pm

Spy does not always see Chrome browser's Dom WebDocument

Post by lyn5000 » Wed Mar 28, 2012 12:49 am

Setup:
Chrome version 17.0.963.83
Open Ranorex Spy

1. Close Chrome
2. Open Chrome
3. In Element Browser tab in Spy click the Refresh icon
4. Navigate to a web site by typing the url in the address box (e.g. bbc.co.uk)
5. Wait until the page has loaded and click Refresh in Spy

What happened:
Dom WebDocument for the page does not show in the tree in Spy; which also means clicking Track in Spy and pointing to an element on the web page will not find anything (nothing gets highlighted by Spy).

If it does not repro close Chrome and try again (repeat from step 1) until it repros.
Sometimes it also repros after step 3 (the home page Dom does not show in Spy).

I have done many tests on Windows on IE 9, Firefox 11 and Safari and these browsers never have this problem.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Spy does not always see Chrome browser's Dom WebDocument

Post by Support Team » Thu Mar 29, 2012 1:05 pm

Hi,

Thanks for reporting this bug in detail.
I already added this bug in our bug tracking system and it will be fixed in one of our future releases.

Regards,
Markus
Ranorex Support Team
.
Image

brendaj2
Posts: 1
Joined: Thu Sep 06, 2012 4:26 pm
Location: Philadelphia, PA
Contact:

Re: Spy does not always see Chrome browser's Dom WebDocument

Post by brendaj2 » Thu Sep 06, 2012 4:28 pm

Is there an update on this issue? I'm having problems when I try to get the current Chrome version.

Thank you!
Brenda

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Spy does not always see Chrome browser's Dom WebDocument

Post by Support Team » Fri Sep 07, 2012 11:02 am

Hi,

The original issue should be solved!
For the next time, please post your question to another or new thread as your question has, in my opinion, not really something to do with the topic of this post.
How did you try to get the version of Chrome and which Ranorex version are you using?

Regards,
Markus
Ranorex Support Team
.
Image

RamyaSubramanian
Posts: 1
Joined: Fri Jun 12, 2015 2:21 pm

Re: Spy does not always see Chrome browser's Dom WebDocument

Post by RamyaSubramanian » Wed Jun 24, 2015 1:46 pm

Hi ,

I am new to this web browser testing and i am trying to test my application in chrome browser.
i did all the settings required for it.
But not getting the DOM page when i track the browser . Kindly help me to solve it .

Regards,
Ramya

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Spy does not always see Chrome browser's Dom WebDocument

Post by Support Team » Thu Jun 25, 2015 12:22 pm

Hello,

The issue was resolved by re-installing Ranorex.

Regards,
Robert
.
Image