Spy is stopping to run.

Ranorex Spy, Recorder, and Studio.
User avatar
FelixK98
Posts: 54
Joined: Fri Apr 08, 2016 6:28 am

Spy is stopping to run.

Post by FelixK98 » Tue Sep 27, 2016 5:35 am

Hi Everyone

I got very strange situation here.
Spy started to crash/stopping to run when I select anything within Chrome browser.

I got Ranorex 6.1.0 and I tried to reinstall it.

Here is the details for Spy and Chrome:
1. Ranorex extension
Ranorex-extension-for-Chrome.png
Ranorex-extension-for-Chrome.png (16.14 KiB) Viewed 857 times
2. Chrome About
Crome-About.png
Crome-About.png (28.37 KiB) Viewed 857 times
3. Spy crash message
Spy-crash-message.png
Spy-crash-message.png (5.81 KiB) Viewed 857 times
Last edited by FelixK98 on Tue Sep 27, 2016 5:43 am, edited 1 time in total.

User avatar
FelixK98
Posts: 54
Joined: Fri Apr 08, 2016 6:28 am

Re: Spy is stopping to run.

Post by FelixK98 » Tue Sep 27, 2016 5:39 am

Hi,

A bit more info for this Spy crash:
4. Windows and PC details
MS-Windows-details.png
MS-Windows-details.png (17.27 KiB) Viewed 856 times
5. Message from MS Visual Studio when I accepted to debug crash
MSV-message.png
MSV-message.png (8.86 KiB) Viewed 856 times

jma
Posts: 111
Joined: Fri Jul 03, 2015 9:18 am

Re: Spy is stopping to run.

Post by jma » Thu Sep 29, 2016 1:49 pm

Hi,

Do you have this issue only when tracking web elements within Chrome or also when tracking other browsers or desktop applications?

Although you mentioned that you already did a new installation of Ranorex, I would suggest doing another new installation following the steps below.

1) Uninstall Ranorex Studio
2) Reboot the machine
3) Install the latest version of Ranorex again and instrument the Chrome browser

Furthermore, make sure that all software requirements are installed properly.

User avatar
FelixK98
Posts: 54
Joined: Fri Apr 08, 2016 6:28 am

Re: Spy is stopping to run.

Post by FelixK98 » Sun Oct 02, 2016 10:55 pm

Hi jma,

Thanks for replay.
I performed all what you suggested, but it didn't helped.
So, I reset Chrome setting to the default settings and re-enabled Ranorex extension and only after this Spy started to work without crashing. Some settings change in Chrome caused Spy to crash when I pointed to the browser element.

Thanks,
Felix.

User avatar
FelixK98
Posts: 54
Joined: Fri Apr 08, 2016 6:28 am

Re: Spy is stopping to run.

Post by FelixK98 » Tue Oct 04, 2016 7:32 am

Hi,

I would appreciate if Support Team will look in it.
I got Spy crashing again. :(
I did all possible steps:
1. Re-installed Ranorex
2. Reset Chrome settings
3. Re-instrumented Chrome

Nothing is helping. I need to resolve it URGENT. :!: :!: :!:

Thanks,
Felix.

jeremy.charpentier
Posts: 1
Joined: Thu Jun 16, 2016 5:25 pm

Re: Spy is stopping to run.

Post by jeremy.charpentier » Tue Oct 04, 2016 8:46 am

Hello,
I face the same issue.
It only occurs on chrome using the spy (tried it with other browsers and with the inspector).

Steps :
- Edit an object within the repository
- The spy is opened on the Path Editor Panel
- Select the Browser and Results Panel
- Ranorex crashes

Additional information :
- A 6.1 project has been created to reproduce
- The tracked object is the query input on the Google homepage
- I tried to re-install Ranorex and the Ranorex Automation Extension

Thanks in advance
Jeremy

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Spy is stopping to run.

Post by krstcs » Tue Oct 04, 2016 1:24 pm

If you want a faster response from the Ranorex Support team you need to use email ([email protected]).
Shortcuts usually aren't...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Spy is stopping to run.

Post by Support Team » Tue Jan 31, 2017 11:05 am

Hi,

The issue was resolved after the customer updated/upgraded his operating system to Windows 10.

Sincerely,
Robert
.
Image