Spy not able to detect javascript alert button in FireFox

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
samantha.chin
Posts: 10
Joined: Mon Dec 28, 2015 10:17 am

Spy not able to detect javascript alert button in FireFox

Post by samantha.chin » Tue Dec 29, 2015 10:02 am

Hi, I have a difficulties in finding element OK button on Alert in Firefox. I tried shift+Lwin but cannot work and am new on this. Please assist. Thanks.

Eg.

1) Go to google and find "w3schools javascript alert example" (P/S: Not able to post the sample URL in this forum)
2) Select the first link "JavaScript Popup Boxes - W3Schools"
3) Click Try it yourself under the Example
4) Click on Try It button
5) Using Ranorex spy to find the OK button

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Spy not able to detect javascript alert button in FireFox

Post by Support Team » Tue Dec 29, 2015 1:40 pm

Hello samantha.chin,

That issue is known and we are currently working on a solution.

Meanwhile, as a workaround, it is possible to navigate to the corresponding dialog elements using Ranorex Spy. These elements can be found within the Firefox form element.
js_dialog.png
js_dialog.png (39.63 KiB) Viewed 1052 times
Please let me know if the workaround solved the issue.

Regards,
Johannes
.
Image

samantha.chin
Posts: 10
Joined: Mon Dec 28, 2015 10:17 am

Re: Spy not able to detect javascript alert button in FireFox

Post by samantha.chin » Wed Dec 30, 2015 2:27 am

Hi Johannes,

Thanks and it worked! Appreciate your guidance.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Spy not able to detect javascript alert button in FireFox

Post by Support Team » Thu Jan 07, 2016 11:04 am

Hello,

There is another way to record/track such dialogues in Firefox.

Please carry out the following steps to change the corresponding Firefox setting:
1) Open Firefox
2) Navigate to "about:config" (enter it in the address bar)
3) Search for "prompts.tab_modal.enabled" and change the value to "false"

Consequently, the modal dialog will be identified as a separate form and not as part of the UI structure of the browser. Note that the previously created path will no longer work after changing this setting.
ModalDialog_Firefox.png
ModalDialog_Firefox.png (17.68 KiB) Viewed 1019 times
Regards,
Johannes
.
Image