Spy/Ranorex not seeing my web DOM or links in it (Chrome)

Ask general questions here.
User avatar
Aracknid
Posts: 363
Joined: Tue Aug 10, 2010 3:23 pm
Location: Toronto, Ontario, Canada

Spy/Ranorex not seeing my web DOM or links in it (Chrome)

Post by Aracknid » Wed Apr 10, 2019 4:00 pm

Hi,

First let me say I'm not having ANY issue with Chrome and my app which is a very complex client/server web app. I'm using 8.3.2 and also testing with 9.0.1. All good.

Oddly enough, I'm working on some new test and I had to make a very simple html page, load it in the browser, find the link, and click it. Here's the html page:
<html>
	<head>
		<title>Link Tests</title>
	</head>
	<body>
		<ul>
			<li><a href="http://www.google.com">Google</a></li>
			<li><a href="http://www.bing.com">Bing</a></li>
			<li><a href="http://www.yahoo.com">Yahoo</a></li>
		</ul>
	</body>
</html>
In IE and FireFox (ESR v60.5), it works perfectly fine. In Chrome (72), it doesn't work. When I launch Spy, it doesn't even see the DOM.

Again, this is using 8.3.2 and 9.0.1

Any thoughts?

Aracknid

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4924
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Spy/Ranorex not seeing my web DOM or links in it (Chrome)

Post by odklizec » Thu Apr 11, 2019 7:15 am

Hi,

If Spy does not detect DOM, it indicates a problem with Chrome plugin. Have you tried another web in Chrome and eventually, uninstall/reinstall Chrome plugin (via Ranorex instrumentation wizard)? Also, are you sure the other browsers and not whitelisted and therefore, Chrome is eventually blocked? ;)

I tried your HTML code in Chrome (via www.w3schools.com) and Ranorex 9.0.1 spy detects both DOM and all links as expected.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration