Spy tool not finding UI Elements on 3D Experience Launcher

Ranorex Spy, Recorder, and Studio.
RDRO
Posts: 1
Joined: Mon May 11, 2020 4:32 pm

Spy tool not finding UI Elements on 3D Experience Launcher

Post by RDRO » Mon May 11, 2020 5:25 pm

Hello,
Small question, I'm trying to make Ranorex works with 3D Experience and I just want to know if it's compatible, or how to tell if it isn't ?
I don't have any issue with the web part of 3Dx but it's the launcher, that call a lighter version module of the full rich client, that I have issues with, I simply can't detect any UI element in it.

Here's a screenshot :
Image

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6181
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Spy tool not finding UI Elements on 3D Experience Launcher

Post by odklizec » Mon May 11, 2020 9:29 pm

Hi,

Please see my answer here...
https://www.ranorex.com/forum/ranorex-o ... tml#p60259

Simply put, there is nothing Ranorex folks can do without proper implementation of accessibility to 3D view of your choice. I know it’s possible, because we’ve done it in my previous work (partially and with great difficulties) for Catia v5 view. So yes, it’s possible, even without full source code of Catia view, just with Catia SDK and some subclassing voodoo. I expect the same possibility for 3D Experience view 😉
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration