SQL server or VS appears to stop Ranorex tests

Ranorex Spy, Recorder, and Studio.
seurrep
Posts: 30
Joined: Tue Aug 07, 2018 10:19 am

SQL server or VS appears to stop Ranorex tests

Post by seurrep » Thu Jan 10, 2019 10:42 am

This only seems to be an issue when running tests that involve a browser (or rather that's the only situation that I've seen the following issue occur). Running entirely non-visual tests that don't require a browser appear to work either way.

The problem is this: if I try and run a Ranorex test plan with either Visual Studio 2015 or SQL Server Management Studio 17 running in the background then when the test plan reaches the stage of using the browser it simply stops. No log. No error. The browser is opened but subsequent actions aren't performed. The little dialog box showing the test being run simply closes and Ranorex studio acts as if the test is no longer being run.

Any idea why this might be? Am currently running 8.3.1 on Windows 10

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4150
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: SQL server or VS appears to stop Ranorex tests

Post by odklizec » Thu Jan 10, 2019 10:50 am

Hi,

Have you tried to add the browser to Ranorex white list? Additionally, I would suggest to check Ranorex trace logs, and eventually share them with Ranorex support.
TraceLogs.png
TraceLogs.png (16.21 KiB) Viewed 22 times
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration