Stability problems of recordings

Ask general questions here.
fleipold
Posts: 37
Joined: Fri Jun 09, 2017 7:04 am

Stability problems of recordings

Post by fleipold » Tue Jul 25, 2017 9:29 am

Good morning,

Were now using ranorex for a month and we still have huge stability problems when executing the recordings.
We encounter a log of problems with not found elements and more "wait for" and "exists2 expressions do not solve the problem for us. We modified the xpath elements to make them more stable but it did not help. The elements normally can be found via the spy afterwards

Can you suggest some more measurements we can perform to figure out why the elements where not found during runtime ? Because currently we need to invest way to much time in getting the tests stable than actually writing any tests

Regards Florian

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3945
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Stability problems of recordings

Post by odklizec » Tue Jul 25, 2017 9:51 am

Hi Florian,

I'm afraid, without knowing more details about your tests, exact errors you are getting, recorded xpaths and AUT as such, there is not much anyone here can do or suggest. Any chance you can post at least snapshot (NOT screenshot) of typically failing element, report with recorded error and example of failing recording (at least screenshot)? These could help us better understand your problem.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

fleipold
Posts: 37
Joined: Fri Jun 09, 2017 7:04 am

Re: Stability problems of recordings

Post by fleipold » Tue Jul 25, 2017 10:00 am

Hello,

Is it possible to get a better error result when a element cannot be found ?
Because currently we only get the information that it could not be found. But checking the xpath the element can be found.
Is there option to get the status of the site at the time when the error occurred ? Any more information about what actually did happen ?

Because its no solution for us to raise a error report each time one of the element which worked for the last five times no suddenly fails.

Regards Florian

User avatar
Stub
Posts: 173
Joined: Fri Jul 15, 2016 1:35 pm

Re: Stability problems of recordings

Post by Stub » Tue Jul 25, 2017 10:04 am

Waiting for repository items to exist and not exist has been key to my tests. In fact I was just analysing one failure just now where it changed the wrong item but validated the correct item. The test failed because the correct item hadn't been changed. This suggested to me a timing issue, so I have added some WaitForExists to ease it towards the correct item.

I frequently do something, wait for the next thing to happen, do something more, wait for that thing to no longer exist before proceeding.

fleipold
Posts: 37
Joined: Fri Jun 09, 2017 7:04 am

Re: Stability problems of recordings

Post by fleipold » Thu Jul 27, 2017 8:26 am

Believe me that we added a "wait for" for the items which where not found during testing. But even waiting for 30s for the item often does not change anything.
Its also not the same item which is failing. You can execute the test on one machine, its failing, youre adding "wait fors" and "delays" for the items and its working, then you run it on another machine and its failing again. Sometimes for the same and sometimes for other items.

And the only information we get is that the element is not available. Checking the xpath it is. So what can i additionally do to get more information about what is going on ? Just adding "wait fors" and "delays" for good measurement is more guessing that actually addressing the specific problem.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Stability problems of recordings

Post by Support Team » Wed Aug 02, 2017 2:32 pm

Hi Fleipold,

May I ask you to send an email directly to [email protected] with a detailed description of your problem?
We could do a remote session if it is necessary.

I'm looking forward to your email.

Sincerely,
Matthias
.
Image