Strange behavior when doing the same action 2 times

Ask general questions here.
ElSticky
Posts: 34
Joined: Tue Sep 17, 2013 1:45 pm

Strange behavior when doing the same action 2 times

Post by ElSticky » Thu Sep 19, 2013 12:02 pm

Currenlty I have created a test case where I need to open a menu two times in the test (a menu similar to 'File' in other applications). When clicking this button you'll get some options like Save as... etc.

When doing this action the first time everything is OK. But when performing it a second time the mouse clicks the menu button and then it should go to f.e. Save as but it close the dropdown and moves the cursor a bit to the right instead.

As far as I know the first and second time are completely the same. I even copied the items to perform the test. Is this a bug, can I fix this by some code or?

*edit

I saw this might be caused by the action before clicking the Menu button. The action before this one is a click on a Close button (to close a pop up window) and then it seems to move the cursor to the Menu button by itself. This shouldn't happen. For the moment I was able to fix this issue by adding another random click which does nothing, then it works fine.

So it looks like there are some steps that shouldn't be there but you don't see them in the recording

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Strange behavior when doing the same action 2 times

Post by Support Team » Fri Sep 20, 2013 3:40 pm

Hello,

Unfortunately I cannot reproduce the issue on my machine. Can you please give us more information?
Can you reproduce the behavior with another application, for example Windows Calculator?
Which version of Ranorex are you using?
Thank you!

Regards,
Bernhard
.
Image