"Supplied XML is not valid" error message

Bug reports.
C-PT
Posts: 4
Joined: Thu May 22, 2014 2:18 pm

"Supplied XML is not valid" error message

Post by C-PT » Wed Jun 04, 2014 10:49 am

Hi!

Since some minor changes in some recording modules, I cannot longer run a TestSuite containing a module group.
This problem effects all module groups, even if they're not in the same project or do not contain any rxrec files. I can create working TestSuites with the exact same function and recording files, if I'm not using module group.

The error message is always the same, but I can't figure the problem out of it. Which file is meant?

rxlog.data excerpt:

Code: Select all

					<activity
					testcasename="TC_Uninstall_IntegrationTest"
					testcaseid="7fd7d0ea-fcdc-4d12-b119-6d184a566f73"
					maxchildren="0"
					result="Failed"
					duration="109ms"
					durationms="109"
					type="test case"
					rid="18fec0dc8054d3d4"
					totalerrorcount="0"
					totalwarningcount="0"
					totalsuccesscount="0"
					totalfailedcount="1"
					totalblockedcount="0">
						<params/>
						<detail>
						</detail>
						<activity
						modulegroupname="Uninstall"
						result="Failed"
						duration="93ms"
						durationms="93"
						type="module group"
						rid="1eeab05e3843144"
						totalerrorcount="0"
						totalwarningcount="0"
						totalsuccesscount="0"
						totalfailedcount="0"
						totalblockedcount="0">
							<detail>
							</detail>
							<errmsg>
								Supplied XML is not valid (file position 86).
							</errmsg>
							<item
							time="00:00.187"
							level="Error"
							category="Module">
								<message>
									Supplied XML is not valid (file position 86).<br/>Die L&#228;nge darf nicht kleiner als 0 (null) sein.<br/>Parametername: length
								</message>
								<metainfo
								stacktrace="   bei Ranorex.Core.FastXml.XmlDoc.parse()
   bei Ranorex.Core.Testing.ModuleGroupTable.CreateFromFile(String fileName, Stream stream)
   bei Ranorex.Core.Testing.TestSuite.get_ModuleGroupTables()
   bei Ranorex.Core.Testing.TestSuite.get_ModuleGroups()
   bei Ranorex.Core.Testing.TestSuiteModuleGroup.get_ModuleGroup()
   bei Ranorex.Core.Testing.TestSuiteModuleGroup.AddGroupModules()
   bei Ranorex.Core.Testing.TestSuiteModuleGroup.Run(DataContext parentDataContext, Boolean childSkip)"
								loglvl="Error"/>
							</item>
						</activity>
					</activity>
Thanks for any suggestions!

Greetings from Austria
Attachments
moduleGroupError.PNG
moduleGroupError.PNG (35.47 KiB) Viewed 1337 times

C-PT
Posts: 4
Joined: Thu May 22, 2014 2:18 pm

Re: "Supplied XML is not valid" error message

Post by C-PT » Thu Jun 05, 2014 8:58 am

The error was found in the rxtmg files of the project. Took some effort to track it down ;)