syncFusion grid cannot be recognized in RanoreXSpy

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
ayman
Posts: 4
Joined: Tue Jun 04, 2013 5:29 pm

syncFusion grid cannot be recognized in RanoreXSpy

Post by ayman » Wed Oct 02, 2013 9:27 pm

Hi,
We have a syncFusion grid integrated in our application, and we are facing a problem of the table grid not being recognized in Ranorex Spy. It just shows as a table node with nothing underneath.
Find attached the snapshot. Any help would be greatly appreciated.

Thanks
Ayman
Attachments
syncFusionGrid.rxsnp
(170.44 KiB) Downloaded 248 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: syncFusion grid cannot be recognized in RanoreXSpy

Post by Support Team » Fri Oct 04, 2013 6:48 pm

Hello Ayman,

Thank you for the Ranorex snapshot file.
It seems that the UI Automation implementation is not correct.
Ranorex uses the UI Automation accessibility framework to recognize the elements. Is it possible to recognize the elements with Microsoft inspect? If you are not able to recognize the elements with Microsoft inspect you should check the UI Automation implementation of your application.
Thank you!

Regards,
Bernhard
.
Image

ayman
Posts: 4
Joined: Tue Jun 04, 2013 5:29 pm

Re: syncFusion grid cannot be recognized in RanoreXSpy

Post by ayman » Thu Oct 24, 2013 6:58 pm

Hi,
I have tried what you suggested and used the Microsoft Inspect tool on the syncfusion grid. I can see some of the datagrid items, please see attached screenshot. I could not see the text value of the cells in the data items though.

Does this imply in anyway that the integration of the syncFusion grid into our software was incorrect?
Do you have any recommendation on how to proceed forward from here?

You support is greatly appreciated.

Thanks
Ayman
Attachments
grid_inspect_screenshot.png
grid_inspect_screenshot.png (93.26 KiB) Viewed 1187 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: syncFusion grid cannot be recognized in RanoreXSpy

Post by Support Team » Fri Oct 25, 2013 3:30 pm

Hello ayman,

Thank you for providing the screenshot.
Yes, it seems that the UIAutomation is not implemented correctly. Please contact the responsible developer or take a look at the following website in order to get more information how to implement UI Automation of a WPF Custom Control.
http://msdn.microsoft.com/en-us/library/cc165614.aspx

Regards,
Bernhard
.
Image