Tabbed view not loading in recording

Ask general questions here.
fraseryates1994
Posts: 1
Joined: Tue Jun 23, 2020 11:03 am

Tabbed view not loading in recording

Post by fraseryates1994 » Tue Jun 23, 2020 11:20 am

Hello,

I'm playing around with the 30 day free trial, mostly going well.

I'm tryin to test an eclipse RCP application with Ranorex v 9.2.1+git.37787e16.

My problem is, when I select a tab in my application, the view doesn't load correctly - the entire view is just blue (the same colour of a selected tab). The first tab in a part stack loads correctly, but when swapping between tabs it doesn't and the test freezes.

When the test is frozen and I click between tabs myself, the tabs load fine and the test will continue as normal. What's causing the view not to load correctly in the recording?

I've tried selecting the tab with a *mouse down* and *mouse up*. And I've tried changing the java settings "refresh java window after injection" from false to true. But no joy.

Thanks

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6036
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Tabbed view not loading in recording

Post by odklizec » Wed Jun 24, 2020 7:17 am

Hi,

At first, Ranorex 9.2.1 is too old and obsolete. Please try to reproduce the problem with most recent 9.3.2. Also, try to reproduce the problem on another machine.

At next, it's impossible to tell what's wrong without seeing the your solution and the app under test. I think even the AUT snapshot would not be helpful here? So I'm afraid, you will have to contact Ranorex support and eventually request a remote session with them, so they can see and analyze the problem.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration