Test holds DLLs of an application thats opened / closed

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Ch_Ef
Posts: 10
Joined: Thu Nov 11, 2010 7:37 am

Test holds DLLs of an application thats opened / closed

Post by Ch_Ef » Mon Oct 15, 2012 1:25 pm

Hi there,

i have the following problem and no idea how to solve it:

Test-Description in an abstract way:
- Open an specific application
- Do something within this application
- Close the specific application
- Do the previous steps again

If this test is driven within a loop, at the second iteration, the application under test does not work correctly anymore, until Ranorex is closed or the test is stopped.

I used the Process-Explorer to verify if Ranorex uses the application´s DLL-files. It´s like that. Now i´m looking forward to find a possiblity of telling Ranorex to release the used DLL-files after each iteration. Hint: manualy testing does not lead to an error.

Is there any hint which leads to a solution for this issue?

Regards,
Christian

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Test holds DLLs of an application thats opened / closed

Post by Support Team » Tue Oct 16, 2012 12:59 pm

Hi,

How do you open/close your application with Ranorex?
Are you getting any error messages?
What do you exactly mean with "the application under test does not work correctly anymore"?
Which Ranorex version are you using?
Are you using invoke remotely in your test script?

Regards,
Markus
Ranorex Support Team
.
Image

Ch_Ef
Posts: 10
Joined: Thu Nov 11, 2010 7:37 am

Re: Test holds DLLs of an application thats opened / closed

Post by Ch_Ef » Wed Oct 17, 2012 9:00 am

Hi,
>> How do you open/close your application with Ranorex?
To start the application, i´m using the following method:

Process prcsFrame = Process.Start(strApplicationPath);

I wrote some functions that uses the application´s menubar (File -> Close) to close the application. After closing the application, it is reopened like shown above. The very first time everything is fine. Application is opened, used and closed. But if the test runs in a loop I get an error message at the second time.

>> Are you getting any error messages?
I do not get any error message from Ranorex itself. But my application throws an error message [“The located assembly's manifest definition does not match the assembly reference”]. I used the ProcessExplorer to have a look after used DLLs at runtime. Within the testprocess, after closing the application, it´s DLLs are still kept by the testprocess. Kept DLLs are DevXpress-DLLs, which handles GUI objects.

>> What do you exactly mean with "the application under test does not work correctly anymore"?
A function which could be started at the first time and opens a mdi-client with DevXpress GUI-controls, starts but throws the error message shown above.

>> Which Ranorex version are you using?
I´m using Ranorex 3.3.2

>> Are you using invoke remotely in your test script?
No.


Regards,
Christian

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Test holds DLLs of an application thats opened / closed

Post by Support Team » Fri Oct 19, 2012 1:45 pm

Hi,

We haven't heard about such an issue before, in general there shouldn't be any such problems.
This seems to be an issue with the DevExpress controls of your application therefore I would also ask DevExpress if this is a known issue on their site.
They may have a quick fix for the issue.

Regards,
Markus
Ranorex Support Team
.
Image