Testing GUI - pull, push and response message

Ask general questions here.
kgasimov
Posts: 16
Joined: Fri Nov 21, 2014 9:55 am

Testing GUI - pull, push and response message

Post by kgasimov » Mon Mar 23, 2015 2:27 pm

Hi,

I try to test GUI using Ranorex automated test tool. But I have following problem:
When clicked on certain button on GUI, the application should be sent pull/ push message to another application(for example : to UI service). Those messages are not visible and it means that I can not validate those messages using Ranorex.
Now, I would like to know, how I can solve this problem? Is there possibility to do this using Ranorex, or I have to use another tool?

Thanks for help.
Kamal Gasimov
Attachments
pull - push message.JPG
Extra information about pull/push messages
pull - push message.JPG (47.17 KiB) Viewed 605 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Testing GUI - pull, push and response message

Post by Support Team » Tue Mar 24, 2015 3:30 pm

Hello kgasimov,

Yes, this should be possible using Ranorex, but it depends on your application.
Does the state of your application change when the message comes back from the web server?
Maybe you can wait for a specific element which only appears when you get the message from the server.
Please give us more information how your application works. If you don't want to provide information about your application in the forum you can also send an email to [email protected] in order to discuss the issue.

Regards,
Bernhard
.
Image

kgasimov
Posts: 16
Joined: Fri Nov 21, 2014 9:55 am

Re: Testing GUI - pull, push and response message

Post by kgasimov » Wed Mar 25, 2015 12:17 pm

Hello Bernhard,

I have sent an email to [email protected].

Thanks,

Kgasimov