testing mobile application using Ranorex

Ask general questions here.
strannik
Posts: 60
Joined: Tue Apr 29, 2014 3:00 pm

testing mobile application using Ranorex

Post by strannik » Fri May 16, 2014 1:49 pm

Hi all,

Trying to test mobile application through Ranorex. I added the device and instrumented my app but I'm getting message No app running beside emulator. The question is which app (Ranorex app or app to test mobile application), and what should I do to resolve the issue?

Thank you.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: testing mobile application using Ranorex

Post by Support Team » Tue May 20, 2014 12:35 pm

Hi Strannik,

May I ask you to provide some additional information?
Therefore, please answer the following questions:
  • Which version of Ranorex is installed on your machine?
  • Are you trying to test Android or iOS?
    • Please have a look at these links for more information about iOS and Android Testing
  • Have you instrumented you application properly?
  • Can you please also attach a screenshot of this error message?
Thank you in advance

Regards,
Markus(S)
.
Image

strannik
Posts: 60
Joined: Tue Apr 29, 2014 3:00 pm

Re: testing mobile application using Ranorex

Post by strannik » Wed May 21, 2014 3:01 pm

Hi Markus,

I have installed Ranorex 5.0.2.17874. I'm trying to test Android and on android device it is saying Ranorex Services 5.0.2. Please see an attachment for details.

Thank you.
Attachments
android.PNG
android.PNG (7.5 KiB) Viewed 881 times

strannik
Posts: 60
Joined: Tue Apr 29, 2014 3:00 pm

Re: testing mobile application using Ranorex

Post by strannik » Wed May 21, 2014 3:14 pm

Markus, I did other application install and instrumented app but still No app running and when I'm trying to do Recording I'm getting the follow message: Failed to start app... I'm attaching screenshots.
Attachments
android2.PNG
Failed to start app file
android2.PNG (41.68 KiB) Viewed 880 times
android1.PNG
No app running file
android1.PNG (8.26 KiB) Viewed 880 times

strannik
Posts: 60
Joined: Tue Apr 29, 2014 3:00 pm

Re: testing mobile application using Ranorex

Post by strannik » Wed May 21, 2014 9:33 pm

Hi Markus,

If I select Start button again I will receive this message (see an attachment) which come ups after "Failed to start app ..." message. Please see ah attachment.

Thank you.
Attachments
android3.PNG
android3.PNG (81.63 KiB) Viewed 871 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: testing mobile application using Ranorex

Post by Support Team » Fri May 23, 2014 2:53 pm

Hi Strannik,

Thank you for the screenshots. As I saw in your screenshots, you are trying to start the Ranorex Service APK within Ranorex Studio. You don’t need to do this. You can simply install the Service application on your device/emulator without instrumenting it.

May I ask you to have a look at our User Guide Android Section.

In this section you can find a detailed description how to automate android applications. There is also a link to an application (KeePass) which is used in our samples.

Regards,
Markus(S)
.
Image

strannik
Posts: 60
Joined: Tue Apr 29, 2014 3:00 pm

Re: testing mobile application using Ranorex

Post by strannik » Fri May 23, 2014 3:48 pm

Thank you, Markus.

I'm already know where is my mistake and solved the problem.