Tests are unable to identify elements when working from home

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
fatima
Posts: 8
Joined: Wed Sep 17, 2014 7:53 pm

Tests are unable to identify elements when working from home

Post by fatima » Thu Dec 11, 2014 6:28 pm

Hi,
I am using Ranorex 5.1.3 and running tests on Windows 8.1 using IE11. I was able to run my test while working from home previously but after I upgraded Ranorex and Windows, all of a sudden sometimes Ranorex does not identify elements at all. Not sure what is that I am missing?
When I run the same tests from my office, they work fine.

Kindly please give some advice of what I might be missing.
Thank you so much,
Fatima

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Tests are unable to identify elements when working from home

Post by Support Team » Fri Dec 12, 2014 1:22 pm

Hello Fatima,

Can you give us more information about your test environment and you applicaiton?
It would be great if you could send us a Ranorex Snapshot file in order to analyze the issue in more detail.
Please also try to uninstall Ranorex completely from your computer, restart your machine and install it agian.

Regards,
Bernhard
.
Image

fatima
Posts: 8
Joined: Wed Sep 17, 2014 7:53 pm

Re: Tests are unable to identify elements when working from home

Post by fatima » Fri Dec 12, 2014 4:22 pm

Hello Bernhard,

Thanks for your prompt reply. I am now even unable to run Ranorex at all from my office too. The strange part is that Ranorex and application browser both reside on my machine. When I run the recording it opens the correct url on IE but then fails at the very first object. If I open the Object in Ranorex Spy, and try to highlight it, it opens another window of some Store already came with Windows 8.1 on my machine. I will send you the snapshot file for in a while. I will also test first if uninstalling/re-installing works.

Please if you have any other pointers, kindly do let me know.

fatima
Posts: 8
Joined: Wed Sep 17, 2014 7:53 pm

Re: Tests are unable to identify elements when working from home

Post by fatima » Fri Dec 12, 2014 4:49 pm

I am attaching the error message that I received after running the test

at Ranorex.Core.Repository.RepoItemInfo.Find[T](Boolean findSingle, Boolean throwException, Duration effectiveTimeoutOverride) at Ranorex.Core.Repository.RepoItemInfo.Find[T](Boolean findSingle, Boolean throwException) at Ranorex.Core.Repository.RepoItemInfo.CreateAdapter[T](Boolean throwException) at TouchPointContainers.TouchPointContainersRepositoryFolders.MessagepointAdmin4AppFolder.get_BranchName_SignInPage50() in c:\Users\fatimaa\Documents\Ranorex\TouchPointContainers\TouchPointContainers\TouchPointContainersRepository.cs:line 48428 at TouchPointContainers.ImportLetter_TP_50.Ranorex.Core.Testing.ITestModule.Run() in c:\Users\fatimaa\Documents\Ranorex\TouchPointContainers\TouchPointContainers\ImportLetter_TP_50.cs:line 208 at Ranorex.Core.Testing.TestSuiteModule.RunInternal(DataContext parentDataContext)

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Tests are unable to identify elements when working from home

Post by Support Team » Mon Dec 15, 2014 10:25 am

Hi Fatima,

Thank you for your reply and for the error message.

Unfortunately it is hard to analyze the issue without having your solution and information about your application.

We didn't receive an email from you until now. Can you please send us the Ranorex Snapshot file and your solution in order to analyze the issue in more detail to our Support Center [email protected].

A detailed description how to create a Ranorex snapshot file can be found in the section Creating Ranorex Snapshot Files on our website.

Regards,
Verena
.
Image