Text validation fail if script is ran part of full suite

Ask general questions here.
LPG
Posts: 39
Joined: Mon Jul 25, 2011 6:12 pm

Text validation fail if script is ran part of full suite

Post by LPG » Thu Sep 22, 2011 10:00 pm

Wondering if anyone has seen something like this before.

I have various scripts that works fine independently, or if I run them together with a couple of other scripts. But when I run the whole test suite together, it keeps failing at a specific place where it has trouble finding an object that is clearly on the page. The step where it fails, is where it tries to do a validation on the text in a field box.

After it fails, if I then run that specific script right away, it passes!

I have added delays, and I have also added extra steps to click on the specific object before it validates it. I have also tried going to a different tab and coming BACK to the specific tab before validating. But as soon as I run the test suite, it fails a the same object again :(

Has anyone had similar issues before, and how did you get around it?

Thanks!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Text validation fail if script is ran part of full suite

Post by Support Team » Fri Sep 23, 2011 1:24 pm

Hi,

can you please provide us a snapshot file of your application under test holding the control you want to validate with your application under test in exactly the state the test fails.
And additionally the c# code of the validation step.

You can either attach the snapshot file directly to your next forum post, or send it to our support mailbox (support[at]ranorex.com).

Regards,
Tobias
Support Team
.
Image