TFS Integration : Build Issues

Experiences, small talk, and other automation gossip.
Venkatesh Katpally
Posts: 5
Joined: Mon Aug 15, 2016 4:40 pm

TFS Integration : Build Issues

Post by Venkatesh Katpally » Mon Sep 26, 2016 4:06 pm

Hi Team,

We are currently facing issues while trying to build the Ranorex Solution on the TFS Build server through Build Agent.

We are able to build the solution and successfully add the solution to the source control and also successfully checked-in the solution as well. But while building on the server, we are not able to do it due to the attached error. Picture attached.

Please give us your thoughts.
Attachments
TFS Integration Build Issue.PNG
Build issue file attached
TFS Integration Build Issue.PNG (150.13 KiB) Viewed 1006 times

Venkatesh Katpally
Posts: 5
Joined: Mon Aug 15, 2016 4:40 pm

Re: TFS Integration : Build Issues

Post by Venkatesh Katpally » Mon Sep 26, 2016 4:08 pm

We have installed Test Agent and also the Test Controller in my Local computer from where I am building the solution.

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: TFS Integration : Build Issues

Post by krstcs » Mon Sep 26, 2016 5:54 pm

If you look at the error, it indicates that you are running the test agent as a service.

In order to run any application that must interact with desktop items, the test agent must NOT be run as a SERVICE! This is true for TFS as well as any other CI system (like Jenkins or Bamboo).

In addition, Ranorex, as well as any other Functional automation tool, requires a fully realized desktop which is unlocked and has no screensaver running, otherwise it will not be able to access the desktop model and interact with elements.
Shortcuts usually aren't...

Venkatesh Katpally
Posts: 5
Joined: Mon Aug 15, 2016 4:40 pm

Re: TFS Integration : Build Issues

Post by Venkatesh Katpally » Mon Sep 26, 2016 9:11 pm

Thanks for the response. I am not finding any Service under the name Agent.

Is there any way to identify whether we have installed the Test Agent and made it Run as a Service ?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: TFS Integration : Build Issues

Post by Support Team » Thu Sep 29, 2016 1:35 pm

Hi Venkatesh Katpally,

Usually, You can view and control the agent running status from the Services snap-in. Run services.msc and look for "VSTS Agent (name of your agent)".

More information about running the agent can be found on the Visual Studio Docs.

Hope that helps :)

Regards,
Markus (S)
.
Image