The Chrome debugging interface was either not found or is no

Best practices, code snippets for common functionality, examples, and guidelines.
thiede
Posts: 18
Joined: Thu Oct 27, 2016 12:13 pm

The Chrome debugging interface was either not found or is no

Post by thiede » Fri Dec 09, 2016 9:58 am

Hi,

I have a website hosted in a form window. On recording some clicks on the website in this form I can't track the items in the website container. Every click is a simple click on this container with a relative position. If I run my recording it works but I get this warning:
  • Warn CEF The Chrome debugging interface was either not found or is not enabled.
I have the Ranorex Automation plugin for Chrome. Do I need some thing else to track the items in my web container and solve this warning?

asdf
Posts: 174
Joined: Mon Mar 21, 2016 3:16 pm

Re: The Chrome debugging interface was either not found or is no

Post by asdf » Fri Dec 09, 2016 2:15 pm

Hi Thiede,

It seems that your application under test is based on CEF.
Therefore, please try to start your application under test with the following argument.

Code: Select all

--remote-debugging-port=8081
2016-12-09 14_11_40-C__Windows_System32_cmd.exe.png
2016-12-09 14_11_40-C__Windows_System32_cmd.exe.png (1.18 KiB) Viewed 1207 times
Afterwards, please try to track the elements in the application.
If this doesn't resolve your problem, please post a snapshot of your application under test.

Hope this helps.

Best regards,
asdf

thiede
Posts: 18
Joined: Thu Oct 27, 2016 12:13 pm

Re: The Chrome debugging interface was either not found or is no

Post by thiede » Wed Dec 14, 2016 2:33 pm

Hi,

thanks for your fast answer. This works some time. In my VM Ware it works. But on my real Desktop it doesn't. I Add Google Chrome AddIn via Ranorex Insturmentation Wizard. But on my Desktop I can't get the elements of the web content. Is there some thing else I have to install?