The tools version "4.0" is unrecognized

Ranorex Spy, Recorder, and Studio.
ablang_58
Posts: 9
Joined: Tue Feb 12, 2013 6:51 pm

The tools version "4.0" is unrecognized

Post by ablang_58 » Thu Dec 12, 2013 11:33 pm

System Support,

Started Ranorex Studio 3.3.3 and the software went as far as indicating it was "Loading..." After a minute or two I tried to load a sample project and received the following error:
Error loading C:\.....\FlexTestSample.scproj:
The tools version "4.0"is unrecognized.......\FlexTestSample.csproj

See attachment for a printscreen of the error message. This message occurs on multiple machines we have version 3.3.3 loaded on. I do have 3.3.3 loaded on my laptop and it operates as expected. Is there a registry setting that was changed, Global setting etc?

These machines are running XP Embeded/service pack 2 with .NET framwork 3.5. See attachment 2 for details

Regards,
Allan
Attachments
system.png
version info
system.png (68.58 KiB) Viewed 3170 times
Ranorex problem.png
error message
Ranorex problem.png (150.05 KiB) Viewed 3170 times

Swisside
Posts: 92
Joined: Thu Oct 10, 2013 10:40 am

Re: The tools version "4.0" is unrecognized

Post by Swisside » Fri Dec 13, 2013 8:54 am

Hello


Can you try with the sample I attached to my post ? (It's form Ranorex 2.3)



Regards
Attachments
FlexTestSample.zip
(35.06 KiB) Downloaded 154 times
A simple thank you always does wonders !

ablang_58
Posts: 9
Joined: Tue Feb 12, 2013 6:51 pm

Re: The tools version "4.0" is unrecognized

Post by ablang_58 » Fri Dec 13, 2013 4:29 pm

Swisside,

First, thanks for your reply but no your version of FlexTestSample generates the same "The tools version "4.0" is unrecognized" error message. I believe the problem is more fundimental. When Ranorex studio is intializing the main screen has "Loading..." displayed but it never completes this task. The "Loading" message is never replace with the latest news from Ranorex.

Regard,
Allan

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: The tools version "4.0" is unrecognized

Post by Support Team » Mon Dec 16, 2013 4:57 pm

Hello Allan,

Unfortunately, .NET Framework 3.5 is not enough for Ranorex Studio.
You would need to install .NET Framework 3.5 with SP1 or higher. Please take a look at our System Requirements page. If you install Ranorex using setup.exe or Ranorex-x.x.x.exe, all prerequisites will be installed on your system automatically.

Please let us know if this solved your issue.
Thanks in advance.

Regards,
Markus (T)
.
Image

ablang_58
Posts: 9
Joined: Tue Feb 12, 2013 6:51 pm

Re: The tools version "4.0" is unrecognized

Post by ablang_58 » Mon Jan 06, 2014 9:02 pm

After installing SP1 Ranorex 3.3.3 installed without issue.

Thanks for the info.
Allan